oil pressure issue

Discussion in 'Oil' started by sooty, Mar 17, 2008.

  1. sooty

    sooty Member

    33
    16
    0
    hi,a long story short...i have a 92 springer and had my bike pulled down in order to tidy things up a bit.problem is now that is all done and bike is back together with a service done too im getting the oil light on all the time.just after it warmed up i give it some rpm and it flickered off but when i went for a short ride it developed a bit of noise in the top end.i thought i had restricked a oil line but fixed the one i thought was the cause but im still getting the oil light on...any ideas?
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Check the actual oil pressure with a gauge to find out where you are at before you toast the motor.
     
  3. sooty

    sooty Member

    33
    16
    0
    ok will do,any ideas on what to do or where to look if the pressure is low??
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    I would go right to the source and check it there ( the oil pump) from there work outwards from the oil pump through the lines that come off the oil pump, process of elimination.
     
  5. sooty

    sooty Member

    33
    16
    0
    job done tiger!!some sneaky so n so must have broke into my joint and swapped the lines so the return and feeder was mixed up.or i must have put them on wrong...
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
    Think it may have been the later of the two.:D

    Glad you got it sorted out.