Oil light use to go off after 3 seconds from igntiion on

Discussion in 'Oil' started by Marc1, Oct 20, 2010.

  1. Marc1

    Marc1 New Member

    3
    0
    0
    Hi guys,
    I need your wisdom here. I have 2007 Softail Custom and just installed a smart security system. Before the system was installed (and since I have the bike), when I turned the ignition “on” the oil indicator lamp illuminates for few seconds and went off, before the engine is running. Then I start the engine. Now, the oil indicator lamp is ON all the time until I start the engine. I called the HD Service Department and they stated that it is how should work, they do not even believe me that the light went off after few seconds of the ignition was on…. I checked with a friend of mine and his bike do the same that mine used to do….What is wrong with this picture? Before was wrong and now is right? Does this have anything to do with the security system? Thank you in advance.
     
  2. Breeze3at

    Breeze3at Well-Known Member

    4,645
    83
    124
    I just checked my '07 Electra Glide, and the oil light stays on until the engine is started, like it should. I have no idea why yours used to go out without engine running, or why your friends still goes out without running. Did your speedo face have the flashing security key light before smart security installation?
     
  3. Marc1

    Marc1 New Member

    3
    0
    0
    Thank you for your respose....So, that means that before was wrong.. I have to tell my friend, probably he is in trouble..hehe.
     
  4. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,279
    133
    157
    The oil warning light goes out when the engine oil pressure is at a pre determined pressure and will come on again if the oil pressure falls below that pressure
    as the oil pump is mechanical and driven by the engine there should be no oil pressure before the engine has started so the light should be on until the engine has started and the oil is up to the required pressure

    Brian
     
  5. Marc1

    Marc1 New Member

    3
    0
    0
    Thank you Brian...got it..