Off to Mobile ...AGAIN

Discussion in 'Touring Models' started by Redfish-Joe, Apr 21, 2011.

  1. Redfish-Joe

    Redfish-Joe Senior Member

    2,307
    48
    10
    More leaks. At least I have factory Customer Service involved finally. If they want to set a new drive train in the frame I won't object but at this point I think the only way to resolve the problem is with a suitable load of high explosives. :D

    Has anyone else had anything like this happen to them or am I the poster boy for bad luck??
     
  2. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    I know I saw something on this but I can't seem to find the post that said what is leaking. Hope whatever it is they can solve it for you.
     
  3. geezer

    geezer Senior Member Contributor

    1,623
    68
    52
    I feel for ya Joe. Good luck again.
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Good luck Joe we are behind you 100 per cent:s
     
  5. Redfish-Joe

    Redfish-Joe Senior Member

    2,307
    48
    10
    Both the primary and transmission are leaking.
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
    Refresh us on where it's leaking again Joe.
     
  7. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Is that at the trans main shaft seal and the inner primary mainshaft seal?
     
  8. Redfish-Joe

    Redfish-Joe Senior Member

    2,307
    48
    10
    Sure looks like it. All seals have been replaced several times. Last go around with it, we did a tracer dye test and they thought the transmission case was leaching oil. Replaced it with a new case. Seals replaced then also!
     
  9. HarryB737

    HarryB737 Junior Member

    656
    26
    1
    Best of luck to you Joe, With the Factory Rep involved this time maybe they'll get to the bottom of it & make you a Happy customer. Please keep us informed.
     
  10. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Wonder if the machined interface where the trans mounts to the engine was done at an angle and the mainshaft is not square to the primary. When they went to the trans engine connection the fit became critical.