occasional miss or skip in engine

Discussion in 'Engine, Fuel and Exhaust' started by biggus, Aug 16, 2013.

  1. biggus

    biggus Member

    6
    0
    0
    My 1993 fxrs has a slight ocassional skip every and any time I ride now. You can see the tach drop for a milli second when it does the miss. I have new spark plugs and plug wires on already. Has plenty of power so it's not loosing that. I don't know if maybe the coil or I assume it's a ignition module under a cover on right side that has screaming eagle on it maybe going bad. Any suggestion's would be appreciated. I know I repositioned the right handle bar controls where engine start and cut off switches are but I think it was doing the miss before that.
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Does this bike have a stock C V carb? This could be a lean hic cup
     
  3. lorne

    lorne Senior Member

    2,426
    58
    18
    i have a 98 that does something similar....does it happen at a certain temp and rmp?
     
  4. biggus

    biggus Member

    6
    0
    0
    It has a S S carb. Bike does sit a lot.

    It usually does it just riding along any speed, I don't think it does it when you nail it. It does it at any temp.
     
    Last edited by a moderator: Aug 17, 2013
  5. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Are you using O.E. plugs and wires ???? Have you tried the wet test on the plugs and wires ???
     
  6. biggus

    biggus Member

    6
    0
    0
    I bought harley plugs and wires at the dealer . What do you mean by wet test?
     
  7. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Wet Test= applying mist of water from a spray bottle on plugs and wires and coils, while slowly increasing RPM at idle to try and duplicate miss to get some direction of what is causing miss. Also check intake manifold for loosness or cracks.