Noise coming from primary

Discussion in 'Touring Models' started by Bearfest, Aug 29, 2012.

  1. Bearfest

    Bearfest New Member

    1
    0
    0
    In April, I purchaced a 2012 Ultra Classic. When the motor would get hot I noticed while stopped and in gear, when I throttled up it would clank in the primary, (at times not constantly). The dealership said that it is the self adjuster, and is between the adjustment, and it will do that. Now that I have reached 5000 miles it seems to clank more often and it sounds like marbles rattling around. I had my bike serviced and the service mgr. said that this is common. he also said I have the latest mapping and a upgrade fix could take up to 3 months. He did say that if I upgrade to stage 2 exhaust and breather, and have the upgrade, that, that would fix it all around.

    Has anyone else had this problem and is there a fix for the noise thats driving me batty. And how can upgrading to stage 2 fix a transmission issue.

    Thanks

    Bearfest
     
  2. cjmoreau

    cjmoreau Member

    25
    0
    0
    I think I am hearing the same thing from mine. I have a 2012 StreetGlide with the 103. I traded a 2009 Ultra Classic with the 96 and never heard the noise like I do now. When I took it to the dealer, they said the 103 are known for that. Let me know if you can find out a way to quiten it down. Thanks Chris
     
  3. Lbaba

    Lbaba Member

    6
    0
    0
    I had an 09, traded to an 11 and now went back to an 06 w/o fuel injection. The marbles in a jar sound is more noticeable along with excessive heat in the newer models so I'm hoping to get 30 more years out of my 06!
     
  4. r_k_dragon

    r_k_dragon Active Member

    270
    0
    4
    I'm running a stock 2011 96 Ultra Classic 22k+ miles and have heard no noises.
     
  5. brownfoxx1

    brownfoxx1 Active Member

    262
    26
    0
    how about going back to the manual chain adjuster? seems this would fix this.