No Turn Signals or Brake Light?

Discussion in 'Touring Models' started by lionsm53, Aug 13, 2010.

  1. lionsm53

    lionsm53 Banned

    122
    0
    0
    Was riding the 09 SG this evening and all of sudden, see a funny little light on the Speedo, and was tryin' to figure it out.

    Tried my turn signals and nothin'. Also after I got stopped, noticed I didn't have a brake light... Hmmmm any ideas, other than busted wire, short, or? Looked in the OM and it said "Indicator Lamps".

    I do have a head light and the bottom tail light on the fender but no brake light or tail lights or blinkers. Could it be a flasher maybe?
    Thanx in advance....
     
  2. Jack Klarich

    Jack Klarich Guest

    Check fuses first, then check for broken or rubbed thru wires
     
  3. lionsm53

    lionsm53 Banned

    122
    0
    0
    Thanks Jack, I was thinking that too...
     
  4. lionsm53

    lionsm53 Banned

    122
    0
    0
    I found it was a fuse and replaced it. It was the ACC fuse. However, when I turn on the ignition, I still get the code, even though I have turn signals and I do have tail light but no brake light, and when I do hit the brake light it seems to blow the "just replaced fuse", so maybe a chaffed wire somewhere....I'm thinkin'?
    Maybe time to take it in to the dealer and let them figure it out....
     
  5. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Maybe check under rear fender for tire hitting wires. It is a very close fit on my bike. Worth taking a look.
     
  6. Redfish-Joe

    Redfish-Joe Senior Member

    2,307
    48
    10
    Had the same problem. Turned out there was a wire pinch in the left switch housing.
     
  7. fisherman124

    fisherman124 Active Member

    293
    0
    1
    should be in the brake wiring if it blows then . did u have seat off pinch a wire putting it back on. ussaully something right in front of u trace the wires back from the tail lite check for anything lokking strange hanging down going around frame , thats what i would do before i took it in
     
  8. lionsm53

    lionsm53 Banned

    122
    0
    0
    I decided to take it in yesterday. I had a couple of factory recalls to do like the tank, maybe the 402 tire, and the kickstand mod if I'm not mistaken.
    My 09 was built in 10/08.