No spark!!

Discussion in 'Touring Models' started by rt69, Jun 3, 2009.

  1. rt69

    rt69 New Member

    1
    11
    0
    I have a 98 Electra Glide Classic with the crane ignition. I have lost spark to both cylinders but have 12 volts to coil continously until cranking. I am not an elecrician but the wiring diagrams for my bike show only 2 wires to the coil and I have 3! I NEED my girl on the road!!!
     
  2. cool breeze

    cool breeze Active Member

    147
    26
    0
    third wire could be a tach
     
  3. jel123

    jel123 Active Member

    157
    26
    0
    You have a single fire crane which has 3 wires the stock wiring diagram only has two sounds like your modual went out ck your wires between coil and modual
     
  4. Bubbaglide

    Bubbaglide Member

    67
    16
    0
    I'll agree with the ignition module diagnosis. A very wise wrench told me that Crane ignitions didn't seem to last as long as some of the others to him. Mine is stock so I don't have a dog in the fight either way. I know there are some who have gotten great service from them but if I go aftermarket, I think I'll go a different way

    Bubba
     
  5. jel123

    jel123 Active Member

    157
    26
    0
    I dodn,t know why crane has this problem but i went thru two modules ans one cracked coil know i have a ultima in mine which is a dyna product but there alot cheaper thru ultima and i have not had a lick of trouble with it so crane is off my list of things to buy buy ultimas complete kit for what you would pay for just the module from crane,jel
     
  6. dhorne

    dhorne Active Member

    258
    26
    0
    You should have 5 wires coming off the module , this is a single fire unit , one goes to the Voes and one for the tack , the other three go to your coil, your module could be burnt as one of the wires to the coil is from the battery , check for power coming out of the coil when cranking , you obviously checked spark , i just had the same problems with my dyna 2000i and had to change it out , I had to change to the fireball crane as I am in venezuela and that is all that was available , i wrote to dyna and they asked me to send it in and they will return it working , these modules that mount in the nose cone don't really like the heat , but lets thank dyna for there service if they fix it,good luck