NO BRAKE lights

Discussion in 'Softail Models' started by muttlange, Jun 25, 2011.

  1. muttlange

    muttlange Member

    77
    16
    0
    Hey Guys, I just discovered i don't have any BRAKE lights. I apply the front and press the rear and NO brake light. I have LED bulbs that are hooked up to a relay, that enables my turn signals and brake light to light up. My turn signals work and all the lights come on at ignition turn, just NO BRAKE LIGHTS. I ckecked the bulb I also checked the relays by bypassing them . I also checked fuses any IDEA?
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Have you checked fuses and the wire harness under the rear fender?
     
  3. muttlange

    muttlange Member

    77
    16
    0
    yes. is there a Fuse for the BRAKE lights?
     
  4. gator508

    gator508 Senior Member

    2,308
    68
    81
    If you had brake lights before the LED conversion, I would look at the connections on the relay. I am assuming it is the one that just plugs into the wiring harness for the lights. If you didn't have lights before, you may want to look at the brakelight switches, one along the rear brake line and one in the right side brake lever housing. Good luck!
     
  5. NYHarley

    NYHarley Active Member

    120
    26
    0
    If you have a voltage regulator inline for the LEDs to function properly, check your voltage before and after the regulator.
     
  6. markols1

    markols1 Member

    13
    0
    0
    G'day if u have changed ur bars or taken ur front brake leaver off and u did not put a wedge between ur leaver and housing for sure u have broken the stop switch it will stay on until it burns the leds out it happend to mine hope this helps cheers Marc (god's country Australia)