Newbie

Discussion in 'New Member Introduction' started by bubbu, Jul 17, 2013.

  1. bubbu

    bubbu Member

    33
    0
    0
    Hello to all. I'm from upstate NY in the heart of the Adirondack Mts. I have a 1987 1100 Sportster that I already claimed one Black bear with about ten years ago. Killed the bear but it didn't kill me, still riding and lovin it. I am having a problem with the Sporty lately. At times when I go to start it I get a single click several times and then it starts. Battery is new, I'm thinking solenoid maybe. Any ideas. Thanks.
     
  2. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,425
    73
    157
    Glad to have you aboard! :ws:rider
    From Central Florida.

    Sounds like the starter solenoid needs to be opened up and looked at. Maybe a rebuild or maybe just cleaning up the contacts will work for ya.
     
  3. Jack Klarich

    Jack Klarich Guest

    Welcome to The Forum
    :rider:ws
     
  4. bubbu

    bubbu Member

    33
    0
    0
    I'll do that, thanks. Thanks for the info.
     
  5. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,963
    103
    360
    :wce From Colorado.
    Also make sure all your batt. connections are clean and tight.
     
  6. Jack Klarich

    Jack Klarich Guest

  7. oldhippie

    oldhippie Senior Member

    1,087
    68
    30
    Welcome to the forum.:cheers
     
  8. SledDog

    SledDog Senior Member Staff Member Moderator

    1,961
    68
    61
    Welcome!
     
  9. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,464
    133
    214
    Welcome to the forum

    Brian
    [​IMG]
     
  10. mat 60

    mat 60 Senior Member

    1,237
    48
    5
    Welcome from Maine..