New ecm works, but tbl light on with no codes

Discussion in 'Electrical' started by relxn88, Jun 23, 2009.

  1. relxn88

    relxn88 Member

    37
    16
    0
    Put a 2005 ECM in my 2002 bike and used the ECM password relearn procedure given to me by GLIDER. The bike started right up and runs great, EXCEPT the light on the dash doesn't ever go out. I have a twinscanII and I cleared any codes, but the light never goes out. I have the TSM (no security)
    Did I miss something on the Password relearn? Should I do it again?
    Open to suggestions.
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    May be something to do with the different year ECM. What codes did you get?
     
  3. relxn88

    relxn88 Member

    37
    16
    0
    Thanks for replying so quickly Glider. I did get a code, but I think it was from the beginning of the relearn, when the fuel pump shuts down, at the beginning of the relearn when you first start the engine. After I did the entire relearn procedure, started the engine, and cleared the code, I haven't had any code failures since. The light just doesn't clear. Would doing the relearn again screw anything up. The bike seems to be running fine.
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    Doubt it would have any bad effects but I don't think that's the problem, still going with the different year ECM. I don't recall the year they went to the faster processors in the ECM but that may be where the problem is coming from.
     
  5. relxn88

    relxn88 Member

    37
    16
    0
    They did change for 2005 from my 2002. The 2005 ECM and the SERT seem to run OK in my bike, except for the check light.
    Two things, do you see any possible problems running it this way, and would a dealer have any way of determining what is causing the check engine light to stay on?
    When I put the old ecm back in, the check engine light goes off a few seconds after the key is turned on. So, I'm guessing there's nothing wrong with the bike, it seems the 2005 ecm is looking(diagnostic) for something its not finding. If the bike the 2005 ecm came off of had security and mine doesn't, would that make any difference? I thought my TSM ,during the relearn procedure, would take care of that problem. But, maybe I'm wrong.
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
    Shouldn't make a difference with/without security.
     
  7. relxn88

    relxn88 Member

    37
    16
    0
    Just giving everyone a final update. Asked the Dealer and he said the 2005 ecm being different than my 2002 that the check engine light is going to stay on and I might as well do what everybody else does - Put a decal over the light. So I did!