Need help with new LED's on old FXR

Discussion in 'Electrical' started by W.Bacon, Apr 19, 2014.

  1. W.Bacon

    W.Bacon Member

    52
    16
    0
    I purchased and installed some LED signals for the back of my FXR. I have running lights, but when I turn on the signal light I get no flash. If I take my test light and touch it to the live wire anywhere in the circuit, my flasher relay will kick in and my turn signal will work, left or right, whichever one I'm playing with. This made me think that I had a ground problem somewhere. I checked and cleaned all grounds on the bike, nothing. A friend says that maybe it's not the addition of the ground that makes it work, but the addition of resistance of the test light. I'm certain that if I wire a small light to each side of my turn signals, they will work. My question, is there a way for me to add this resistance to my LED's so that my flasher relay will kick in, without adding lights to the circuit.
    I hope my question makes sense.
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  3. wazzle

    wazzle Member

    98
    0
    0
    I used the OE Harley replacement LED turn signals. They don't require a load equalizer.
     
  4. W.Bacon

    W.Bacon Member

    52
    16
    0
    Thanks Jack. The link you provided led to a much better understanding of things for me, and I'm one step closer to having my project bike completed.
     
  5. Bartman420

    Bartman420 Member

    43
    16
    0
    I purchased a set for another bike and had the same issue. they were Kuryakyn. Their equalizers didn't work correctly so I went with a Badlands equalizer......problem solved.