Mystery Electrical Connector, what's it for??

Discussion in 'Touring Models' started by Butch, Jun 23, 2010.

  1. Butch

    Butch Active Member

    227
    26
    0
    While changing my idle cable, I noticed a 3 prong connector attached to the upper motor mount, located directly under the tank (pix below). The wiring for it goes across the backbone and disappears into the harness on the other side. I could not locate a place to plug it into and both the shop and parts manuals have no information on it that I can find. From the looks of it it has been unplugged for a long time. I'm thinking it may be a circuit test access point but it seems odd that it's open to the elements. The battery was disconnected, so I don't know if it's hot or not. Anybody know what it's for?

    The bike is a 99 ultra with a M-M EFI, stock, except for a stage 1 kit.
     

    Attached Files:

    • A.jpg
      A.jpg
      File size:
      48.7 KB
      Views:
      80
    • B.jpg
      B.jpg
      File size:
      49.1 KB
      Views:
      77
    • C.jpg
      C.jpg
      File size:
      41.5 KB
      Views:
      72
  2. Wayne R

    Wayne R Active Member

    228
    26
    0
    I dont know what thats for , but I would think there should be a end plug in that to protect it from water especially being so low on the bike.
     
  3. Breeze3at

    Breeze3at Well-Known Member

    4,645
    83
    124
    My '07 has a connector that was att. to my air cleaner housing. Mine is for something on International models only, not U.S.. Maybe yours is the same?
     
  4. ultrat

    ultrat Senior Member Contributor

    1,315
    0
    1
    maybe for ca. models like the air cleaner solenoid shutter.