Musical "jingling" coming from shift linkage

Discussion in 'Transmission' started by Mavagrand, Apr 13, 2009.

  1. Mavagrand

    Mavagrand Senior Member

    1,250
    48
    12
    Sitting at idle the other day and noticed a musical "jingling" thought it was my Gremlin bell but, when I put pressure on the shifter, the noise stopped. Put bike back in neutral, jingling again. Reached down and put slight pressure on the shift linkage, jingling stopped. Then noticed I cold stop the noise as well by placing my foot against the shifter peg. Wondering if this is a symptom of linkage failure or if it means something else might be going on wtih my tranny. Any ideas?? Thanx.
     
  2. DavHJ

    DavHJ Member

    77
    18
    2
    I had the same problem with the all stainless shifter linkage from the HD acessory catalog. I just put one small o-ring behind each heim joint, put the bolts back through and the musical "jingling" went away.
     
  3. glider

    glider Veteran Member

    25,464
    108
    44
  4. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    Have you removed the rear shifter?
     
  5. Mattman4403

    Mattman4403 Junior Member

    602
    26
    1
    If you have the hemi joints they have just become worn. You can replace just the joints If you have the original joints I would get that thing replaced. Those things just don't last for me. Perhape is is the 2.25 inch over shift levers put a bit more torque on them but I have found it best just to junk the original linkage and replace it with one with hemi joints. I had not heard of the o-ring thing. I may give that a try next time before replacing the joint.