Motor cuts out after about 30 miles

Discussion in 'Electrical' started by Ando, Jan 8, 2008.

  1. Ando

    Ando Member

    5
    11
    0
    Hi guys Im having trouble with my 1999 sporty it cuts out after about 30 or 40 miles riding, it feels like its electrical as I've been right through the fuel system and its all clean including the cock in the tank.
    It coughs and dies you pull over turn the key off and then back on and away it goes again. the battery is ok, any Ideas would be appreciated, I suspect coil but dont really know much about the engine management system on the bike.
     
  2. Ando

    Ando Member

    5
    11
    0
    Hobbit thanks mate I'll check the reg/rec caus our fuel dont ice much up here in Aussie it 40c in the shade. cheers tho
     
  3. glider

    glider Veteran Member

    25,464
    108
    44
    Other areas you can check would include the ignition switch connections and main circuit breaker which could cause you these problems also. Clean and check the battery terminals for corrosion and tightness.
     
  4. Tatanka

    Tatanka Member

    63
    16
    0
    When It Dies, Stop, kick stand it, and look to see if you have any headlights,etc. This may help you locate the problem. A friend of mine had a bad cell in his battery and it would flop around sometimes in the battery shorting it out, and the bike would die.
    Last winter, I took apart every electrical connector on the bike down to the light bulbs, clean them with contact cleaner, and regreased with Elctrical grease. I found 5 corroded terminals on a 6 year olf bike.
     
  5. Twisted_Games

    Twisted_Games Member

    32
    16
    0
    This may be crazy, But I have seen the fuel cap not venting and cause a suction on the tank after several miles. just something to check.
     
  6. Tatanka

    Tatanka Member

    63
    16
    0
    my 97 did the same thing. There was a problem with the pet cock on carb models. The diaphram would close and stop the fuel.
     
  7. Ando

    Ando Member

    5
    11
    0
    Well after a lot of messying round with everything I found the key switch to be faulty so I installed a new one and I dont reckon its ever run better.
     
  8. glider

    glider Veteran Member

    25,464
    108
    44
    Glad you found the problem. The switch is the first place I look, it's a rather common thing as I posted above. The first place to start looking.