low fuel light

Discussion in 'Touring Models' started by mrfinley, Mar 23, 2012.

  1. mrfinley

    mrfinley New Member

    3
    0
    0
    Hello
    Name here is Mike and I have a 05 ultra , The low fuel light
    does not come on but the gauge works just fine. I was wondering if there
    is a replaceable bulb in the speedo that can be changed or if anyone has had this problem and know the fix for it..
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Harley Davidson Community Have a look here first:s
     
  3. Hoople

    Hoople Account Removed

    7,198
    0
    34

    Mike, This may help also. I don't know how they did it in 2005 but on my 2009, the speedo low fuel light is actually a LAN communication instruction set. Does your speedo LCD display the time of day and if so, does the display change to "miles to empty" when your on your last gallon of fuel.

    That is how mine operates. If your speedo works the same as mine, you 1st need to determine if the LCD speedo display recognizes the last gallon of fuel. Does your speedo count down the last 30 miles to empty when it's on the last gallon even though the low fuel light is blank?
     
  4. mrfinley

    mrfinley New Member

    3
    0
    0
    No The 05 works off the fuel gauge. It does not have a lcd display in it.It is suppose to come on with 1 gal left. So either has to be a burnt out light in the speedo head or something else..The else is what i need to figure out...
     
  5. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    Have you run it Lower that the gal left when you are expecting the light to come on?

    Maybe your not empty enough... Knowing how many miles to a gallon is important as to figure where the fuel is in the tank. The light is a very small bulb and I have never had mine out or needed to.

    If it was working before???
    it more likely the bulb? OR the giismo that turns it on.:D


    signed....BUBBIE
     
  6. mrfinley

    mrfinley New Member

    3
    0
    0
    well i have it down to 4.8 gals....still not light...The problem is the speedo is a sealed unit. no way to get to the bulb
     
  7. btsom

    btsom Active Member

    341
    38
    6
    Anybody know what wire he needs to connect to a power supply to light the light? At least that would tell him if the "bulb' LED or what ever it is is working. If it works off a coded signal on a serial data line that sounds like a dealer check. If it works from a computer card in the speedo, then another speedo is his future if he wants the light to work. Nobody knows how this thing works and how to at least test the bulb??
     
  8. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Wait a minute, are you saying on your bike you don't a LCD display to read codes from? You can't perform a normal WOW test and have all the lamps in the speedo turn on?