Loud engine sound "clunk clunk"

Discussion in 'Engine, Fuel and Exhaust' started by cdn-bigfoot, Jul 23, 2009.

  1. cdn-bigfoot

    cdn-bigfoot Junior Member

    2006 Street Bob Dynaglide 88 inch with stage 1.
    This happened twice within minutes of each other. Got a loud 2 clunks in a row from what sounded like the front cylinder. Engine seemed to stall out or slow idle briefly. Immediately the engine light and battery light come on. The engine ran fine after the first 2 clunks. When I restarted the engine a few minutes later it started and ran fine for 5 minutes, then one loud clunk and the engine light came on. I ran the DTC check and only came up with the low battery code. Cleared the code and ran it... No codes. Am I safe to run this bike to diagnose the clunk better? any ideas?

    Just went for a little ride. No more noises. Engine light and battery light come on. Is it possible that the loud clunk was my alternator? I'm going to put my bike on charge overnight. But I think it's time for a new battery anyway.. I'm still a little unsure of that noise and why it coincided with my charging issues.

    I think I just found my problem in a discussion on electrical.

    I must have blown up my rotor. That's what the sound was. And it explains my sudden charging issue.

    Rotor problem HDTalking discussion.
    Last edited by a moderator: Jul 24, 2009
  2. DonT1985

    DonT1985 Member

    I ran into a similar problem on a older harley. Of course their was no check engine light system. The problem turned out to be a loose compensator nut. The nut was hitting the primary cover and the stator shell stripped out the splines causing the charging system to fail under load. This may not be the answer but gives you one direction to go in.