Lost radio display

Discussion in 'Communications And Radio' started by Redfish-Joe, Aug 30, 2009.

  1. Redfish-Joe

    Redfish-Joe Senior Member

    2,307
    48
    10
    This was the second time this happened. The last time I was near the Harley store in Biloxi. Dropped in, left the bike running and got the service writer to check it out. Radio worked fine but no display.

    Kill the bike and start it up again, everything works fine.Anyway he wrote it up and put his contact info on the work order.

    He said since he had it documented I shouldn't have any problem getting it replaced/repaired where I get my bike worked on in Slidell.

    It would be nice if they do accept his findings and not have to keep my bike to "reproduce" the problem.
     
  2. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    101
    They are all independent dealerships, and sometime they have an attitude "if it wasn't done here, it wasn't done right". Fraid you will have to "endeavor to persevere"!

    TQ
     
  3. Redfish-Joe

    Redfish-Joe Senior Member

    2,307
    48
    10
    I'll find out tomorrow. :s
     
  4. vtbikers

    vtbikers Active Member

    174
    26
    0
    I would go back to Biloxi and se if they will fix it. Its really not that far from slidell.
     
  5. Cajun Ultra

    Cajun Ultra Active Member

    111
    28
    1
    what did they find out about it ????
     
  6. Redfish-Joe

    Redfish-Joe Senior Member

    2,307
    48
    10
    They got me a brand new remaned one coming. They dont service them in store.:D

    I appreciate what the service writer did for me there. It was one of those right place right time things. I have had a few issues with the store in the past.

    Slidell has always treated me with respect.
     
    Last edited by a moderator: Sep 1, 2009
  7. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Can't do better than that, a good relationship with a reputable dealer is HUGE!
     
  8. Redfide

    Redfide Member

    11
    1
    0
    This happened to me while my bike was under warranty. The dealer reflashed the software in the radio and it came back and worked ever since. Its been a year now (knock on wood).
     
  9. Redfish-Joe

    Redfish-Joe Senior Member

    2,307
    48
    10
    I'll give them a call and see what they think. Thanks!
     
  10. Lancer

    Lancer Junior Member

    495
    28
    2