LED lights help?

Discussion in 'Softail Models' started by BonzaiBerger, Jul 12, 2010.

  1. BonzaiBerger

    BonzaiBerger Member

    8
    1
    0
    I'm changing my brake and rear turn signals over to LED and i was wondering what kind of load resister I need for these, or is it one per light?
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
  3. BonzaiBerger

    BonzaiBerger Member

    8
    1
    0
    Thats a great link! Thank You
     
  4. rlb333333

    rlb333333 Member

    15
    0
    0
    they should all be set up,,ready to use ,,
     
  5. DEW57

    DEW57 Member

    55
    6
    0
    Just put on led turns, rear, led running and turn on front, led fender tips and brake with the 3 flash then on for the tourpak from Custom Dynamics. Good products and service.
     
  6. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    LED rear stop/tail light works great, the ones that have programmable flash rate even better...! For the turn signals I chose Halogen projector lamps...they are plenty bright and do not need equalizer as they draw 35 to 50W (same as OEM) but at least 10 times brighter.
     
  7. mike_h

    mike_h Member

    10
    0
    0
    just brunt a led tail light out on my 2007 softtail 320 canadian to replace went back to factory o and the light was brought in 2008
     
  8. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Hmm for $320 Canadian, you could have bought K├╝ryakyn Red or Clear (Blackout) BRIGHT LED one for half that...think mine was $135 USD....and it was plug and play. Others have used ones that have programmable sequenced flashing before going on solid when coming to a stop for maybe $50 USD more...I would shop around....
     
  9. glyd-n

    glyd-n Junior Member

    406
    26
    1
    I would definitely shop around for a better price. I picked mine up for $50 brand new. They are programmable to flash and then solid when braking.
     
  10. rydahog

    rydahog Active Member

    228
    26
    0
    today i had this co. install my 2011 SG, rear plasma lites, looked good, etc..but 100 miles later in my garage,,NOT working right rear?

    so now 100 mile ride back to see if they repair these? or are the vibrations to much for these lights?

    sorry thought this was for touring section,but lites are lites i guess,,,:)