K&N oil filter problem?

Discussion in 'Touring Models' started by HDSickness, May 23, 2011.

  1. HDSickness

    HDSickness Banned

    418
    0
    2
    I just switched to a k&n oil filter after running hd filters and now when started oil light stays on 5 to 10 seconds when before it would go out in about 2-3 and also just noticed today oil light came on at idle. Anybody else experience this?
    99 road king twin cam.
     
  2. ckhismine

    ckhismine Active Member

    141
    26
    0
    All filters are not equal. I would switch back to a Harley filter. Seen other filters cause problems on a lot of bikes.
     
  3. glider

    glider Veteran Member

    25,464
    108
    44

    If you read the many posts on oil filters, you'll find that many choose to try different brands and sometimes come up with something that is not normal when compared to an HD filter.
    Your problem may be associated with the drain back valve in the filter OR it may not even have one. I suggest to anyone contemplating an after market filter to stick with the HD filters, they are specked for the engine and not a compromise to fit many applications like other companies do.
     
  4. HDSickness

    HDSickness Banned

    418
    0
    2
    I wanted the ease of removal with the k&n I guess its not worth it.
    will be swapping out as soon as dealer opens tommarrow.
     
  5. 03ultra45385

    03ultra45385 Active Member

    146
    28
    3
    buy the oil filter tool and go with HD filter'
     
  6. wilks3

    wilks3 Junior Member

    623
    0
    1
    Is the oil pressure switch in-line between the oil pump and oil filter?
    Could it be that the higher flow of the K&N filter doesn't trap some oil pressure so oil light comes on?
    I think I would check oil pressure of engine also.
    And trust me I'm not wanting to start a arguement, just thinking what problem is being masked by the low micron rating (restrictive) of HD filter, instead of higher flowing filter.
    wilks3
     
    Last edited: May 23, 2011
  7. dbmg

    dbmg Experienced Member

    5,800
    153
    318
  8. HDSickness

    HDSickness Banned

    418
    0
    2
    Last edited by a moderator: May 24, 2011
  9. HDSickness

    HDSickness Banned

    418
    0
    2
    Well if anyone is interested I changed the filter back to an HD filter and took about a 50 mile ride and everything is back to normal. Think it is a good idea to stick with what works. Parts guys think maybe a bad K&N filter or restrictive flow compared to HD. Either way I can ride with peace of mind again.:D
     
  10. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Sometimes it just doesn't pay to mess with success.