K&N Filter now stumbles

Discussion in 'Engine, Fuel and Exhaust' started by WillM, Jun 12, 2013.

  1. WillM

    WillM Member

    13
    0
    0
    I just replaced my old air filter with a new K&N on my 02' FLSTF. the carb is an S&S. The old filter was pretty dirty, but now with the new K&N, the bike seems to stumble/hicup when accelerating just a little. Seems that there could be a slight hesitation if I really get on it. I don't know much about adjusting these carbs, but willing to dig in. any suggestions? thanks
     
  2. Slo-Ryd

    Slo-Ryd Junior Member Contributor

    487
    28
    18
    Sound like it's getting more air now with the cleaner filter that flows better than a stock one. My only suggestion would be to make sure the accelerator pump is squirting properly. That should be the only reason for a stumble other than an intake leak or a slow jet that's too small. Check those two areas first (Acc Pump and/or leak) and maybe richen up the mixture screw a quarter turn at the most and see if it improves.
     
  3. WillM

    WillM Member

    13
    0
    0
    Thanks....that's just what I did. I think I didn't adjust the mixture correctly after installing the filter. I forgot to tighten down the accelerator pump adjustment screw before adjusting the mixture. So it was back to the basics. I tightened down the acc. pump adjustment to make sure it did not affect my mixture in any way. I readjusted my mixture setting and then readjusted my accelerator pump. Just took it for a ride and it's running very smooth, good acceleration. Now I'm a happy camper!
     
  4. 50ronnie

    50ronnie Member

    16
    0
    0
    Had same problem. Thanks for the info
     
  5. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,595
    103
    296
    Good advice BigAl66, well done.