ignition switch

Discussion in 'Touring Models' started by tourglider, Jun 17, 2010.

  1. tourglider

    tourglider Member

    I ride a 95 tourglide ultra( the Mistress).last year I had trouble with the starter not running now and then. Replaced relay,replaced starter switch,rebuilt soloniod,checked
    starter. Hot wire from battery to solonoid always worked. This winter I replaced the ignition switch. Worked great for about 2 months now we are back to the same problem. Remedy? Aftermarket button on back of starter. last month I and 4 Harley and a wing rode up to Green Bay Wi. for LZ Lambeau. 2 ultras and mine, a fat boy and a sporty. When we were leaving I had to use the after market button. One of the other ultra owners said you have one of those too? He was having the same problem. Now according to my unoffical survay, 2out of 3 ignition switches are junk. Think Harley could have fixed this by now. China don't make good switches.
  2. stefdustin

    stefdustin Member

    I have a Rk which of course has dash mounted switch. I had the same problem. I bought 2 after market switches in less than a year. NOTHING BUT TROUBLE! I finally took the factory switch apart and found much green corrosion. I am sure this was cased by moisture. I cleaned everything up real good and made it look shiny new inside. I then went to a electonics supply store and talked to a counter salesman and told him the problem I was having. He sold me a aerosol can of marine corrosion preventative spray. I sprayed the swith and have not since had any more problems. It has been 3 years. I also took the aftermarket switches apart and did them the same way. I have a friend that has been using one of those on a custom build for 2 years with no problems. If the factory switch on the ultra will come apart it can probably be saved. Sometimes we have to finish building the parts the factory uses.