Idle sounds like big cam in bike

Discussion in 'Engine, Fuel and Exhaust' started by luthr428, Jun 23, 2014.

  1. luthr428

    luthr428 Member

    8
    0
    0
    I have recently had the top end rebuilt on 2001 FXSTI 88 cu in. I presume bike is stock except for vance and hines staggered shots. Engine had lifter noise and was found to have heavy carbon buildup. Heads and pistons were cleaned, new rings, valve job, new lifters and rocker arm bushings, and had all cam bearings replaced. Idle sounds like a bracket racer car. Accelaration is very strong under throttle. While cruising @ 20 in 2nd, 30 in 3rd, 40 in 4th, engine has big cam lope sound and bike seems to stumble or possibly surge. While cruising on highway @55 or so bike acts like electrical will shutoff and back on for only a split second.
    I will also advise my turn signals flash 6 times when being started. Code by flashing turn signals says 31. Bike has no alarm. Please advise.
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  3. luthr428

    luthr428 Member

    8
    0
    0
    My 2001 softail standard has fuel injection and a stock air cleaner. Does anyone think the problem is the tsm? Can a dealer test the tsm or would they just install and hope that fixes part of the problem?
     
  4. dolt

    dolt Senior Member Contributor

    1,815
    83
    206
    Take the bike back to the builder and have that code run down before doing anything else. The builder has a responsibility to deliver a smoot running motor after a rebuild; pursue the issue with the builder until you can't.:58:
     
  5. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    You say you presume the bike is stock, so I take it you are not the original owner. How many miles were on the motor before the rebuild? When whoever did your top end and replaced the bushings and cam bearings, did they not notice if there was an aftermarket or Harley upgraded cams? Were the pushrods changed out to the adjustable type? A little more info. and we may get to the bottom of your problem.
     
  6. anthonyflhx

    anthonyflhx Member

    10
    0
    0
    Start with builder and if he cant help a local dealer or indy may be able to.
     
  7. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Historic 31 Alarm output low This is your trouble code, if i am not mistaken the alarm runs thru the TSM
     
  8. luthr428

    luthr428 Member

    8
    0
    0
     
  9. luthr428

    luthr428 Member

    8
    0
    0
    I am not the original owner. Pushrods were not changed out to adjustable. I was told the cams are stock. Engine sounded like this before and I found a cracked vacuum hose that is a plug on the back of the throttle body.
     
  10. luthr428

    luthr428 Member

    8
    0
    0
    builder says bike runs strong which it does. Also was told after removing at least a 1/8 inch of carbon build up from pistons and cylinder heads that it would run a lot different than before.