Idle problems wiith TFI

Discussion in 'TFI Settings' started by cyborg, Jul 30, 2010.

  1. cyborg

    cyborg Active Member

    242
    28
    1
    After installing TFI on my 09 Dyna it now Idles very high. Dobeck said to set Pot #4 to 7 o`clock. But it still idles a little high. Anyone have any ideas?
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Normal idle is 950-1050, what are you calling high?
     
  3. cyborg

    cyborg Active Member

    242
    28
    1
    All i have to go by is the sound, FXDC has no tech.
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    How are you determining that it's idling high then?

    The standard idle to most seems a bit high by ear.
     
  5. cyborg

    cyborg Active Member

    242
    28
    1
    I think most people that own a bike know there bike and know when it’s idling too high or too low. And I know it didn’t idle this high before I installed the TFI. Maybe i`ll just buy a power commander and end this headache.
     
  6. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    cyborg; I know it's tough to judge w/o tach, but my FLHX idles a little over 1K until warm where it sets at 950. Now I don't have the GEN3 TFI so my pots set different, but find out which sets idle & back it down (with warm bike) until it sounds right. Also, Dobeck Tech Support is on HD Takling so you can send them your issue too...good luck!
     
  7. Hoople

    Hoople Account Removed

    7,198
    0
    34
    I have this feeling if you remove the TFI your idle will remain where it is. Sounds like you may have an air leak in the intake side.

    Even if adding fuel DID increase the RPM, the IAC control stepper should kick it back down and that is not happening. The Target idle RPM is a software value.
    If the idle is not correct either the IAC stepper is not working, the engine is never coming out of warm up mode due to a temp sensor failure, the stepper is pegged at the lowest extreme in an attempt to correct the curb idle or you have an intake leak.

    (As it applies to the 2009 Avatar bike.)
     
  8. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Cyborg, so many here on the forum are using the TFI, and with the posts I've read about their support, I think you should talk to them before you spend any more $$.
     
  9. glider

    glider Veteran Member

    25,464
    108
    44
    What you posted is true about you knowing it high but as posted above, the stepper motor will return the idle speed to the parameters set in the fuel table in the ECM from the factory. Your problem undoubtedly is not the TFI causing the higher idle you have but another problem like mentioned above like an intake leak possibly.

    I would pursue the trouble shooting to find out why it's idling high before spending more money for the PC only to find you have the same problem after that installation too.
     
  10. HOLY DIVER

    HOLY DIVER Junior Member

    430
    0
    2
    i just installed a TFI and when i pull up 2 a stop sign now it idels down a touch low then picks back up and idels normal.now when this happens it only lasts for a few seconds then like i said it picks back up and idels normal.it does not feel like it is going to cut off or anything. i just can notice it doing it. should i pay it no attetion and just ride?or do i need to adjust one of the pots?or all of them?