Idle changes

Discussion in 'Dyna Models' started by hogtyd, Sep 7, 2010.

  1. hogtyd

    hogtyd Member

    72
    16
    0
    My 2007 lowrider has a habit of the idle changing from time to time. Last weekend I was riding and the outside air temp was around 70 deg. I came to a stop sign after running about 60 mph for about 1/2 hour. when I stopped the engine was idling at about 1700 rpm after about 5 seconds it dropped to 1050. then after about the same length of time at 60 mph I slowed down and turned into adrive way and turned around and stopped it was idling so slow I thought it was going to stall. I kept it running by reving it a little then it caught hold and ran at about 1050 again. could the engine temp sensor cause this? it ran fine all summer till this weekend the temp dropped to about 75 and this started. any suggetions would be appreciated. thanks
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Has your bike had the Torque Smoothing download done, my Streetbob did the same thing, seems some 07 models slipped thru without it, call your dealer with your VIN:s
     
  3. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Jack might be onto something.
    If the temp sensor is running outside of parameters the check engine light should illuminate. Might want to check for vacuum leaks at air filter/ intake manifolds.
     
  4. nvsteve

    nvsteve Member

    76
    0
    0
    There are some issues with some IAC motors. You can also try cleaning the IAC valve with carb cleaner. It worked for me.
     
  5. hogtyd

    hogtyd Member

    72
    16
    0
    Thanks for the helpful hints guy's. I went by the dealership last night and bought a temp sensor($41.00) now all I have to do is do some alteration on my 3/4 deep well socket so the electrical plug on the sensor will fit up inside of it. I guess I have more money than smarts to try this first, but it just makes sence that it does this mostly when the engine is warming up or when we have a big change in the outside temperature. I had this bike in the dealer's shop about 2 months ago for this very problem. They checked for vac. leaks and every thing but the temp. sensor. The tech. took the bike out for a test run and ran into the back of a pickup truck with it (minor damage no one hurt) needles to say after they replaced all the damaged parts I am a little hesitant to take it back.(They never did find the problem) when I first took it to them the service mang. said he thought it was the temp. sensor but after the crash they didn't get it back to check it. I'll keep you posted on the results.
     
  6. Hoople

    Hoople Account Removed

    7,198
    0
    34
    You just described two different sensors. Which temperature sensor did you buy? Air intake temp sensor (outside air) or the cylinder temp sensor.

    Warming up= Cylinder temp sensor
    Big change in outside temperature= Air Intake temperature sensor.
     
  7. hogtyd

    hogtyd Member

    72
    16
    0
    The cyl. temp sensor.
     
  8. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Give it a shot. It may fix it but I would be very surprised if it did. Reason,,, even if the temp sensor told the ECM it was 40* below zero, the warm up idle would not be 1700 RPM. It does not have that much range.

    My money is on IAC. $20 to WIN.:p (and a $20 to PLACE cover bet)
     
  9. lowrider13

    lowrider13 Active Member

    113
    28
    1
    I also have a 2007 lowrider that will stall on occasion but seems to be doing it more often now. I took it to the dealer and they checked the temp sensor,iac, fuel processor. They said everything is within parameters.Problem is it throws no codes,I am thinking it is the IAC motor also.There is a tech tip...TT-410 about 07 idle issues. It is a pain not knowing if you are going to make it home.

    -------------------------------------------------------------------------

    Is this free or is there a charge?
     
    Last edited by a moderator: Sep 8, 2010
  10. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    This is free if it hasnt been done yet, call the dealer with the VIN, you will be happy knowing one way or another, Mine was stalling and not idling, now problem is fixed, Good Luck