hit bump in road engine light came on in my 99 dyna low bike cut out and wont start

Discussion in 'Dyna Models' started by froggy1111, Aug 22, 2010.

  1. froggy1111

    froggy1111 New Member

    2
    0
    0
    last night i was riding and hit a large bump {welcome to nj} my engine light turned on and the bike immeadately cut out naw it wont start i dont hd put dump safeties on the bikes also how do i meater the coil bike has 10 k on it se cams, lifters and heavy breather please HELP: bigsmiley22:
     
  2. fisherman124

    fisherman124 Active Member

    293
    0
    1
    ld look for a broken wire or one jared loose does it crank if not check starter wires for tightness good luck i hate electric check fuses might of shorted and blew ???

    welcome see u new here , some others will chime in . iam in pa by the burl bristol bridge
     
    Last edited by a moderator: Aug 22, 2010
  3. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Start at the source the battery and check all fuses and grounds:s
     
  4. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    100
    Like Jack said above. Start at the battery and work outwards.

    I think your year has the bank-angle sensor built in to it, but that is to cut off the bike if the lean angle gets over 45* (I think). It is reset by going through a key-switch ON-OFF cycle a number of times (three I think, but I would have to check my Owner's Manual). I doubt that is it, unless you dumped the bike after hitting the bump/hole.

    More than likely, some wire is loose or damaged based on what made contact. Just start tracing. If you do not get any cranking at the starter, after ensuring that the battery cables are tight at both ends of both cables, then make sure the solenoid wire has not come unplugged.

    TQ
     
  5. froggy1111

    froggy1111 New Member

    2
    0
    0
    engine cranks but no spark i changed coil with new one but still no spark what is the reset sequence? ill try that dont want to have to go to local $hd$
    _____________________________________
    gad and petcock good as well
     
    Last edited by a moderator: Aug 23, 2010
  6. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    100
    Reset for the Bank Angle sensor is 3 ON-OFF cycles of the main switch. But I am not sure your model has that. May be the touring bikes only. Check your Owner's Manual if you have one.

    Are you getting power to the coil? If not, have to figure that out. If you have power to the coil, but no spark, then you are not getting the trigger signal from the ECM to fire the coil. I would first worry about the Crank Position Sensor at the front of the engine near the oil filter. Check this out:

    Crank Sensor (CKP) - Harley Davidson Community

    Starting point.

    TQ