High idle problem

Discussion in 'Engine, Fuel and Exhaust' started by sjcea, Sep 5, 2013.

  1. sjcea

    sjcea Active Member

    104
    0
    0
    This just started the other day on my FLHXI Street Glide 2006 . while riding and then coming to a stop I noticed the idle running high ( about 2100 rpm ) no idea why it did this ? I hitbtje throttle a few times an no change ? It stated to come back to normal after a few minutes . bike sat at work for 9 hours . when I went to go home and started it cold . the idle raced up again over 2000 for about 15 seconds then dropped ? What's causing this ? Bike has just over 20k miles . dirty IAC or perhaps a bad TPS ? Any help would be appreciated!!
     
  2. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    Could be either...disconnect the TPS plug from behind your a/c intake, ensure it's clean, coat pins with dielectric grease and then re-connect.

    Also, when turning off EFI bikes, make sure you let the motor "idle-down" to 1K before shutting off. The TPS will recall last setting and high idle conditions are know to crop-up, when you turn-off @ anything other than normal idle.
     
  3. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Clean the Idle Air Control.
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    If this is not throttle by wire, try lubing your throttle cables, I had 1 cable break last year on the road, it did the same thing you describe here:s
     
  5. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  6. sjcea

    sjcea Active Member

    104
    0
    0
    06 model not 09
     
  7. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
  8. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    My mistake, I was running a split screen at that time, that post still bares reading tho it has good info about a high idle found in the self help section:D
     
  9. sjcea

    sjcea Active Member

    104
    0
    0
    I cleaned the IAC today and i would say it was pretty dirty . went ahead and cleaned the rest of the air intake as well while I was at it . fired the bike up afterwards and it was idling normal . throttle response seemed a bit more snappier than before . if this doesn't solve it I will replace the TPS as well
     
  10. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Why? A bad TPS won't increase idle speed by 1000 RPM. You need more air to do that, not more fuel.