Hiccup

Discussion in 'Softail Models' started by Goofuss, Aug 4, 2009.

  1. Goofuss

    Goofuss Active Member

    131
    26
    0
    I have an 06 Softail Std EFI. Over the last couple of rides to work, I have started to get a hiccup at cruising speeds. I am going to add a TFI(need to save just a little more) will this help or could this be that I need new plugs. Stage one was done before I bought it. Thank for the help that I know that I am going to get. You guys and gals are great.
     
  2. 03classic

    03classic Junior Member

    424
    26
    0
    might try running some injector cleaner through it.
     
  3. glider

    glider Veteran Member

    25,464
    108
    44
    Hard to say about the plugs without posting the mileage but the TFI will help the lean condition if you are running the stage 1 dealer download.
     
  4. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    100
    Give us a bit more detail on the conditions that cause these "hiccups". Is this when you roll-on or roll-off the throttle? Is it at a particular rpm or range? Is it just one "hiccup" or a series?

    TQ
     
  5. Goofuss

    Goofuss Active Member

    131
    26
    0
    Its got 8000 miles on it. It will do it at any speed. I notice it more when I am holding a steady speed. It is almost like the motor cuts out for a second. It does seem to happen after it is warmed up, about 20 miles into the ride.
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
    Just install the TFI and it will probably cure the hiccups.
     
  7. Goofuss

    Goofuss Active Member

    131
    26
    0
    Thanks.
     
  8. jfbloom

    jfbloom Member

    21
    1
    0
    The TFI pretty much took care of the same hiccup problem I had with my '06 fxsti.
    I am pretty happy with mine. Good luck.