Help with fuel assemby reinstall

Discussion in 'Touring Models' started by BigDog1954, May 2, 2010.

  1. BigDog1954

    BigDog1954 Member

    Hello all, I just remplaced the fuel quick connect + hose and installed new fule filter. Removed the fuel assembly ok now ready to install. While reinstalling all going well except it will not completely reseat around the gasket flush without putting some pressure downwards. Based on the location of where I have to put pressure it appears something around the fuel pump is not letting sit all the way down. When I removed the assembly it was resting flat no gap. Does anyone have any idea what might be holding from seating all the way into the tank. I have checked everywhere I can see and don't see what is holding it up. I know it probably something real simple but I am stumped.

    Any help would be greatly appreciated!

  2. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    Make sure the hose you just replaced is routed over to the right side of the tank over the center "mound". It may be getting under the bottom of the fuel pump keeping the plate from laying flat. Additionally, I assume you got the swivel point back locked straight so that pump and float arm are laying straight down rather than to the left. If they are laying to the left, they could make contact before the plate is flat. Other than those things, if neither of thise seem to be the problem, try to "eyeball" where the interference is coming from. Not much room to get your eyeball in there, but take your time and fiddle it out.

    BTW, if you smoke, don't do it while trying to eyeball in the gas tank!!


    NEWHD74FAN Experienced Member Retired Moderators

    TQ, why would you think he would have a problem "eyeballing" the fuel tank...looking at his avatar or be smoking with his arms full...LOL