Help Please!!!

Discussion in 'Touring Models' started by mikelljames, Jun 20, 2014.

  1. mikelljames

    mikelljames New Member

    1
    0
    0
    I have a 2008 Ultra Classic. I have a K&N air cleaner true dual exhaust Cobra fi2000 fuel pack and 255 Screamin Eagle cams.
    When I am riding and the bike is warmed up I pull up to a stop sign my bike acts like it is going to die idols down to around 500 to 600 RPM's.
    I put the Cobra fuelpak on because I had a vance and Hines fuelpak thought that might be the problem. I have 70,000 miles on my bike and am really at a loss as to what the problem could be. I've tried new plug wires and spark plugs change my fuel pressure relief valve new fuel filter still no change. please help!!!!!
     
  2. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    Check the sensor in the front head... The ET engine temperature sensor.

    That is one overlooked sensor that can cause this type problem... I have No first hand knowledge, nor how to check it but have heard it here someplace...

    Welcome.

    Others will be along soon to help.


    signed....BUBBIE
     
  3. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,317
    73
    130
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Harley Davidson Forums Check your codes first just because, I agree it sounds like the temp sensor, they are cheap and not hard to replace If you look behind your horn on the back of the front head you will see a rubber boot the sensor is in there
     
  5. bcortani

    bcortani Active Member

    392
    28
    3
    "
    Others will be along soon to help."

    You know, this is why HDTalking is one of the best sites on the net.:D No matter the problem, someone here is always willing to help. Between the first three responders, they will have you well covered!!
     
  6. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    [​IMG] number 6 is the temp sensor