HD charging system

Discussion in 'Other Service and Maintenance' started by danroo, Sep 3, 2012.

  1. danroo

    danroo Member

    7
    11
    0
    Ok here we go I ride an 08 Ultra classic. While riding the other day the voltmeter dropped from 14 to 12 and would not move even when revved up.....I checked and the battery was border line so I installed a new one. Still the voltmeter read 12 and at one point while increasing the rpm it went up to 16 and I immediately shut it down, the voltage regulator is approx. $250.00 and the stator is $150.00 or so plus install. Is there a quick way of determining which component is the problem as electrical parts are non returnable. Anyone help me out there? I heard there was a check one can do with a multimeter!
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    http://www.hdtalking.com/archive/t-47714.html Here u go and report back:s
     
  3. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Should be 1/2 that amount. Unless you live in Canada, somebody is quoting you crazy prices.
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  5. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Jack, I actually was going by my 2009 38 amp regulator. My regulator # 74631-08 is $120 MSRP and $96 discounted. I was figuring the OP's regulator couldn't even be in the $200 range but it is. I am 3 phase at 38 amp. I wonder what makes his so much more $$.
     
  6. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    HMMM, good question, I may have to call my buddie in MN on this one:s
     
  7. texas tom

    texas tom Active Member

    131
    0
    1
    Is the 08 different than 07 ? I just bought a chrome one for my 07 $139.00 ,But he first needs to determine where his problem is dont want to start throwing parts at it!
     
  8. Rydn4fun

    Rydn4fun Member

    31
    0
    0
    Tom did you buy from Local dealer or order online interested in getting one for mine as it is suspect in my isssues my dealer quoted $240 for the OEM
     
  9. texas tom

    texas tom Active Member

    131
    0
    1
    I bought from a indy shop its a drag specialties (I think) so its not oem did not price one from harley been running it since june no issues..
     
  10. texas tom

    texas tom Active Member

    131
    0
    1
    Rydn4fn,what problem are you having with your charging system? Just a bit of background on my original problems ,about a year ago my stator was leaking oil and I was having some intermittent problems,bike would idle high like 2k then when I stopped would return to normal also at times it would idle so low that it would die,but returned to normal when come to a stop.Took it to HD they changed my stator under warranty,but could never dup riding probs,these issues never resurfaced,I suspect the flaky stator was causing them.About 3 months after changing stator my battery stranded me had to trailer bike home wound up buying new battery. all was good for a few months then suddenly batt lite came on volt was 12 and dropping went home did a few checks no output at all from volt reg with 26 vac at stator,changed volt reg now good. The point im making is it seemed as if one thing led to another,a flaky stator takes out batt poss also damaged the reg,but when reg went it went no intermitts like stator and or batt may have given. Good luck Tom..btw your near leakey ever done the loop just got back last month..Awesome..