hazzards flash but turn signals dont!!!

Discussion in 'Softail Models' started by lwolford, Nov 28, 2010.

  1. lwolford

    lwolford New Member

    3
    0
    0
    ok fellas , i got the 1998 softail custom real nice scoot, but i need help with the turn signals, they will not flash, the hazzards flash fine, i can work the signals manually ... but who wants to do that!! is there a seperate flasher and can some one tell me where it is?? thanks fellas.
     
  2. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,277
    133
    156
    There should be a tsm turn signal modual that controls the turn signals however this modual requires the correct wattage to be drawn through the system before it operates correctly
    so if you have changed any of the bulbs with lower wattage ones this could be the cause of the problem

    Brian
     
  3. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    I think you have a bad TSM and believe it is in side the head light bucket
     
  4. lwolford

    lwolford New Member

    3
    0
    0
    ok thanks fellas ill try to find it, what does it look like??
     
  5. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,277
    133
    156
    My fxstc is a 92 and mine is located on the underside of the top frame tube between the 2 tanks it is a black box with a 10 pin plug on one side yours may be slightly different but not by much consult your service manual and it should be able to give a location and description

    Brian
     
  6. bbeavers76

    bbeavers76 Member

    5
    0
    0
    Check your fuses as well. I was blowing fuses for a while due to a false ground and my lights were doing the same thing.