Having problems with heated grips....

Discussion in 'Touring Models' started by bellacoolabilly, Sep 27, 2008.

  1. bellacoolabilly

    bellacoolabilly Member

    17
    11
    0
    I have a 2004 Electra Glide Classic with heated grips that aren't working. I was told that if they were Harley Davidson grips, they often stop working
    (for no apparent reason) and the only solution is to get new ones. I checked the fuses in the panel and there does not appear to be any that are blown. They have the dial on the side (left handle bar grip) on the end that goes from "OFF" to "6." Any suggestions would be appreciated.

    Cool Hand(s) Luke
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Best to check for power up near the grip itself. They do have a habit of going bad especially when water is in the equation.
     
  3. glider

    glider Veteran Member

    25,464
    108
    44
    I agree with the heated glove. Much better than just the palm of your hand warm, besides, the palm is the last place to get cold, the back of your hand takes a beating with the heated grips unlike the gloves.
     
  4. bellacoolabilly

    bellacoolabilly Member

    17
    11
    0
    Thanks guys. I never thought of heated gloves. It does make more sense overall and will save money for more stuff on the bike.
     
  5. Fatboy07NH

    Fatboy07NH Banned

    48
    0
    0
    I had the same problem. The problem was a result of water in the left grip. I almost guarantee that if you remove the left grip it is probably full of water.

    My grips were only 4 mos. old when they failed. Contacted the dealer and they gave me a new set at no charge.
     
  6. bellacoolabilly

    bellacoolabilly Member

    17
    11
    0
    Thanks Fatboy07NH. I'll pull them off and check them out. I'll send a shot back reporting what I find. Did they happen to say why the grip was so easy to fill with water? Seems like a fault in the design. This only promotes "fair weather" riding...LOL!
     
  7. Fatboy07NH

    Fatboy07NH Banned

    48
    0
    0
    All tehy said was it's a known problem ???? Not sure what that means. My Lady has had the same grips on here bike for 2 seasons and has not had any problems.

    When I install the new ones I am going to put a bead of clear silicone at the end of each grip. Hopefully this solves/prevents the problem from re-occurring. Time will tell.

    Good luck.
     
  8. 06ultrascreemingeagle

    06ultrascreemingeagle New Member

    1
    11
    0
    I have a 06 SE ultra and the factory heated grips stopped working. only 10k miles. The mechanic said wiring in left grip shorted out, probably water. he put the grip back together and i will get heated gloves also. With grips at $200+. Gloves are cheaper.