hard starting

Discussion in 'Dyna Models' started by kicks33, Dec 1, 2013.

  1. kicks33

    kicks33 Member

    22
    13
    1
    Every morning when i started the bike,it start with one click.But when i rolled the to city,about 15 miles and i stopped for a gas,it hard to start.What causes this engine behavior.No code is coming out.My bike is 2008 FXDB
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Do you have any tuners on the bike? What is changed on the bike since it was new.
     
  3. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Does click mean, one push of the starter button? and hard to start in the city, does it mean slow or no crank, crank but no run???? Please explain..:s
     
  4. kicks33

    kicks33 Member

    22
    13
    1
    No upgrade since new,Its all stock,It crank when i started,it take 3 time attempt before it started.Please help.It has 7500 miles on it.Hard starting when hot.
     
  5. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Did this hard starting when hot just start? No codes? This could be as simple as a bad temp sensor located behind your horn on the front head, pull back the rubber boot and check the connections
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
    Do you have stock plugs in it? What's the number of them?
     
  7. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  8. kicks33

    kicks33 Member

    22
    13
    1
    no code comes out,I replaced stock plug(6R12) with screaming eagle(PN 32192-10)the trouble is just started a couple of days.No problem starting in the morning.Ill checked the sensor at the back of horn as jack said.

    Good day.Already checked the connection and wiring of eng. temp. sensor,cleaned connector,Nothing found problem with the connector and wiring.I started the bike with 1 click of the starter button,run the bike at idle for7 min,then i stopped and started again,It takes 3 attempt before it start.The problem still same.Waiting for help.Thanks
     
    Last edited by a moderator: Dec 3, 2013
  9. glider

    glider Veteran Member

    25,464
    108
    44
    Do you have the tools to check the fuel pressure? Possibly a problem with with either the internal fuel line in the tank or even the fuel filter itself causing low fuel pressure, there was a problem with the filters.

    The reason I say this is because the auto fuel enrichment would richen up the mixture in the morning (cold) and not richen it up when warmed up.
     
  10. kicks33

    kicks33 Member

    22
    13
    1
    'I dont hace tools for testing f.o. pressure.What i have here is basic maintenance hand tools,a v.o.m.The mechanic is 700 km from my place,the harley davidson of manila.Please help on how to fix with the trouble.

    I ride the bikes for 30 miles and the trouble were gone.(high idle,low idle and hard starting when hot.)Just this morning i try to fix the trouble of my bike,I started by removing air filter and backing plate,disconnect AIC connector,cleaned connector with electrical cleaner and also also the temp sensor,cleaned also thr connector and mounted back.The tested run for 30 miles.All the trouble were gone.Thank you very much to all of you guy who help me trouble shot my bike.Agains thanks to Glider,Jack Klarich.
     
    Last edited by a moderator: Dec 4, 2013