Gurgling Rattle when Accelerating Hard

Discussion in 'Touring Models' started by gafergus, Aug 23, 2007.

  1. gafergus

    gafergus New Member

    3
    11
    0
    I have a stock 2005 Road King Classic (FI) with less than 10k miles that has a strange sound when I roll on the throttle hard. My best description for this is a gurgling rattle.

    It is worse when the engine is hot or it is really hot out 90F
    It is worse under load (uphill or two up)
    It stops as soon as I let off the throttle
    There's no backfiring.

    Am I running too lean?

    I'm considering getting a 3rd party DFO/TFI to richen it up a bit (plan on getting louder pipes soon too).

    Could the add-in help my problem? Anyone else have this issue?

    Thanks,
    Gary F.
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Difficult to nail it down with a sound as you said, but do you have a stage 1 on the engine (K&N air filter) and have you checked the exhaust gaskets for leaks?

    Any engine code lights in the speedo lit?

    The TFI is a good choice as long as you don't intend to build the engine with head work and cams. Very easy setup and install.

    Give us more info if you can about the noise and where it seems to come from on the engine.
     
  3. gafergus

    gafergus New Member

    3
    11
    0
    Thanks for the quick response....

    But
    No Stage 1 (purely stock)
    No Engine Lights

    It's hard to tell when riding but it sounds like it is coming from the heads area.

    Gary F.
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    The heads area is around the intake, check your air cleaner to make sure it isn't loose and that the head breathers are in place, there's one for each head that go into the air box.
     
  5. glider

    glider Veteran Member

    25,464
    108
    44
    I was using premium in all my vehicles for years and found that some like it and others don't quite need it as much. The objective of premium is that it burns slower in the cylinder to give more power and can actually cause more heat in doing it.

    Various factors such as compression ratio, cam etc will need premium but with the specs for the stock HD, it really isn't necessary unless a ping is heard using a lower grade gas.

    I have found that 91 octane sunoco or other major brands works well and actually feels like it runs better than 93 premium. Of course if you have that one in a hundred bike that needs the 93 octane, then stick with it. Pinging and detonation can destroy an engine if left unmanaged.

    Just my observations.
     
    Last edited: Aug 24, 2007
  6. gafergus

    gafergus New Member

    3
    11
    0
    It is definitely an internal engine noise versus an external engine noise. It is acutally kind of similar sounding to a lugging engine but this is occurring at much higher RPMs and typically only when hot.

    It does seem better when I use 93 octane verus 91 octane, but when hot 95-100+F it still happens.

    Gary F.
     
  7. glider

    glider Veteran Member

    25,464
    108
    44
    Only thing that would come to mind is the compensator nut backed off in the primary. If you want to pull the cover and check it , it's not a big deal to do.

    Compensator Torque M1170.pdf

    View attachment 4214

    There was some problems with the nut bottoming out before the torque was reached on the compensator nut.It can be remedied by using a shim or milling the nut itself.
    The shim for the compensator assembly is Part#24033-70. It's .090 and keeps the compensator nut from bottoming out before the proper torque is reached. Red locktite after a thorough cleaning and get the new tightening sequence instead of the torquing procedure you are using now.

    The amount to cut off the nut if you go this route is 0.030" if you are milling the compensator nut (30 thousandths of an inch) ~ 1/32"
     
    Last edited: Aug 27, 2007