Gen 4 Install

Discussion in 'Engine, Fuel and Exhaust' started by tourbox, Mar 5, 2013.

  1. tourbox

    tourbox Senior Member

    1,309
    68
    54
    Well I got my Gen 4 on 2/28/13,I think. I couldn't install it til Sat. 3/2/13. I had several delays during the day so it took awhile. This was going on my 2012 FLHTCU, which is stock exhaust & a/c. I started by puling off the stock headers w/ cats and replacing with stock headers off an '09 FLHTCU,no cat,ya hoo. After that the gas tank & outer fairing came off. I then placed the unit in the ABS box which was empty.Velcro-ed it in place. Ran the wiring in the factory channel and tie wrapped,loosely, in place.Next hooked up the gauge,FI connectors. and ground. The '09 headers has the 18mm fitting already so that was plug & play also. That wiring goes up the left frame down tube into the factory channel also.Now almost ready to start and play. After putting the tank back on and hooking up the battery I hit the start button. I had read the instructions,for some reason(lol) and kinda new what to expect. When I turned on Ign. the gauge & lights cycled as stated, Sooooo I hit the start button.LO & Behold it fired right up. I let it warm up good then went thru the set up for each function with the lights. Quick test ride. 3 mi., to fill the tank. Seem to run pretty good. I was doing a breakfast/brunch run on Sunday so decided to play with the setting more then. That was about 125 mi. so plenty of time for adjustments. I kept looking for the Yellow light while cruising but the Yellow & Blue were on. I tried different Transition settings, up & down, but couldn't get a Yellow only.This worried me but couldn't call Dobeck till Monday. The bike ran very good though. I called them on Monday morning and talked with a gentleman named Nick.He told me that was normal for the Yellow & Blue to be together for cruising. The blue signifies that the O2 sensor is active(closed loop) & the Yellow was in cruise. I was much relieved. Now today I took her on another 125mi. run. I went North so I could run into a strong head wind from an incoming front system. About 50 mi. north I hit it, 35-40 mph head wind.Y/Bl light switched several times to r/bl. That is normal due to extra load from the head wind. I re-adj. the r/bl from 13 afr to a 13.5 afr. System went back to the y/bl and stayed in the cruise zone. When I turned back South I re-adj. the r/bL back to a 13 afr. It stayed in the y/bl all the way home. I was very pleased with being to get out the power mode(r/bl) back to the cruise(y/bl) for economy as the Instructions said you could. I called Nick back and told him of the 2nd. run & that I was very pleased with the unit. I told him about the switching and thought I had it down pretty good, I don't know about all that though. I also checked my MPG for this trip because of the wind. Normally with that kind of wind I would get in the very low 30's. Today I went about 50 miles with a 20-25 angle cross wind to 10-12 miles of 40mph head wind,back to 10-12 miles of 40mph tail wind. back to about 50 miles of 20-25 cross wind. I ran back out of the front when going back South. This was all flat road, except a few Overpasses. Running at 65,70, and 75 mph. About 80 miles was at 75 mph. Oh my mpg was 39.88, I was happy. Now for a Calm day to do it again. Any way I am Very Pleased withe the Gen 4. I like watching my AFR's going down the road,the cruising,switching zones, and the like. The bike seems to have a whee bit more power, smoother acceleration and no De-cel popping.I didn't have any popping to start with either. Sorry for the Long thread but I just had to get it out to someone. I highly recommend the Gen 4,thanks Bubbie for turning me on to it.
    tourbox
     
  2. Sourn

    Sourn Member

    48
    0
    0
    Thanks for the info, good write up, sounds like it really works good. Now I know they have them for my bike, I have a Gen3 and was looking to get a Gen4. Please post more info when you can on Gen 4, thanks.
     
  3. tourbox

    tourbox Senior Member

    1,309
    68
    54
    I will post more at a later date. If I remember I'll even use paragraphs(lol). No pics though. I may be kin to Capital Jack.
    tourbox
     
  4. Rubyred

    Rubyred Senior Member

    1,020
    48
    11
    Very good write-up tourbox! Thanks for the time you took to post this thread, much appreciated.:s
     
  5. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    LOL, good deal for you, this was a very good write up, pictures what pictures We dont need no stinkin pictures, Enjoy your new toy:p
     
  6. tourbox

    tourbox Senior Member

    1,309
    68
    54
    Well a little update. I've got about 1,700 mi. on the Gen 4 now and I'm still very pleased with the unit. Wife & I went to the the Texas Hill Country a couple weeks back with no problems.
    Was traveling in the 75 mph range with AFR's set at 14.5. Slightly loaded down(wife's stuff) and got right at 41 mpg. Slightly windy, but not bad. Plenty of power in the hills and on the highway.
    Next trip may adjust AFR's a little leaner for the highway for possible better mpg. Just don't know when next trip is other than Mich. some time in June. Maybe "Just Kickers Rally" in Okl. this month. May take the Hard Tail to that one though.
    tourbox
     
  7. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    :D Looks good, pretty impressive mileage:D
     
  8. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    Good write up on your Gen4.
    Yes on paragraphs:s easier to read.

    I'd ask you to do the QUOTE of the first post,,, then re work the spacing Just making paragraphs, then ASK Tank to place it (modified paragraphs) on the Dobeck site..


    You'll get the hang of adjusting the AFR's and I also do the same MONKEY with it from time to time. Easy and can change it to ANY AFR setting I want to use.:yes

    I have found @ Cruise (yel-blu locked in) i get my best at 14.5 to 14.7 setting. Never too lean as I have my Green at tad left of 13 for slower Non pulliing cruise,,, almost on the 1 of 13............
    Twist Throttle a little, PULLING Cruise LOCKS Into the yel-blu for the good mileage:s

    Plenty of power and good mileage also Cooler running of my 09 FLHR 96".
    I have the full stage one and SE255 cams.

    I DO set my red at 12.5 where SAE clams motors get best performance (so does Mark)... It does get up and SCOOT...

    signed....BUBBIE
     
  9. mike the bike

    mike the bike New Member

    2
    0
    0
    Nice post tourbox, thanks.
    I'm in the process of ordering a Gen 4 for my 09 FLHTC which has a stage 1. I'm just trying to get things arranged to do a Stage 2 Big Bore on it and also get the heads ported and flowed as well.
    I have a fuelpak fitted at the moment but they don't do maps for when the head is ported. This is what got me originally looking for another tuner and the Gen 4 looked just the job and Dobeck have been really helpful in getting me sorted.
    I would like to get the Gen 4 up and running before doing the Stage 2 then I know everything is working and should only need to re-tune. Your post will certainly be a help in that!
    I'll re-post when I get it fitted and let you know how I'm getting on.

    :)