FXDWG electrical problem

Discussion in 'Dyna Models' started by brentm, Sep 5, 2009.

  1. brentm

    brentm Member

    48
    16
    0
    I was out yesturday on my 2007 wideglide when she shut down for a split second (the hole bike died) then came wright for another 10-15km before starting to miss and (EDIT) around, the hole electrical system would shut down then start and so on till it came to a holt, I checked me Battery and noticed it was a 12V and only 8AH battery and not an origonal Harley one, i check the battery when i got her back home and it was dead flat. does this sound like just a classic case of someone installing a cheaper chinees Battery or should it still run fine with the altarnator?.
    looking forward to your replys

    How about conveying your thoughts in a grown up way?

    Please read and understand the info in this link...
    [note]
    A Friendly Reminder - Harley Davidson Community
    [/note]
     
    Last edited by a moderator: Sep 5, 2009
  2. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,278
    133
    157
    First thing id check in your situation is that you have a good connection at both ends of the battery cables
    bad connection could cause the symptoms you described

    Brian
     
  3. Spade5

    Spade5 Active Member

    236
    26
    0
    I agree with fin. Bad cable connections can cause all sorts of problems.

    I honestly do not know if she will run just off the alternator but I suspect not.

    Since you have to charge the battery anyway, you may find it will not take or hold a charge. Here in the states most auto supply stores have a load tester to see if the battery is good. You are running a lot of electronics on an 07 and proper voltage is needed.

    I think the HD battery is a very good choice. I doubt it is the cheapest and may not be the absolute best but it is a good one. I have been told they will last 4-5 years.