fuel pump problem 2006 streetbob

Discussion in 'Dyna Models' started by wiggler2006, Apr 3, 2009.

  1. wiggler2006

    wiggler2006 New Member

    4
    11
    0
    hi can anyone help ?while out riding my streetbob a week ago it started to cut out on me but restarted 3 or 4 times until finally it stopped altogether ,i have full ignition but fuel pump wont come on i found a broken wire on a turn signal but it still not coming on ive changed ignition switch also but still nothing , the diagnostics is giving me pn34329-06 but the dealers here in ireland tell me its not a correct harley part number?i checked the relay in another bike and thats ok. any help would be brill
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    You have to check the wiring for the pump to see where you are loosing the power to it. It's the only way of telling if it is the power to the pump or the pump itself. The part number is normal for all bikes to display and means nothing as far as troubleshooting.
     
  3. wiggler2006

    wiggler2006 New Member

    4
    11
    0
    cheers glider i know the pump is ok because i can get power to it by bypassing the relay. do i need to password learn the new igntion ?
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    If you replaced the ignition, it opens the power to the system especially if you disconnected the battery cables, not sure about this but it wouldn't hurt to try it.
     
  5. wiggler2006

    wiggler2006 New Member

    4
    11
    0
    thanks glider can i get the procedure here?
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
  7. wiggler2006

    wiggler2006 New Member

    4
    11
    0
    thanks glider i tried this procedure earlier but the security light ie the key symbol would not stay on and theres no check engine light on my bike