Fuel gauge stopped working

Discussion in 'Electrical' started by 01 rk, Aug 12, 2013.

  1. 01 rk

    01 rk Active Member

    317
    26
    1
    On the way to Strugis the fuel gauge stopped working, always reads full, at the same time the instrument lights went out on the fuel, air temp and oil pressure gauges.
    Is there a test for the fuel gauge/ sending unit to find out if one is bad or shorted out?
    The bike is a 2006 flhtci with 76k.
    I suspect there is a short some where in the system but don't know where to start looking.
    In June the battery, stator and regulator went bad and were replaced in that order, each time the charging system was checked and the out put was 14.5v.
     
  2. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Why not check for good grounds under fairing?
     
  3. 01 rk

    01 rk Active Member

    317
    26
    1
    Thanks dbmg will start there, and get back with results.
     
  4. STEVE07

    STEVE07 Well-Known Member Staff Member Super Moderators

    4,034
    68
    42
    Take a test light and check all of your fuses.
     
  5. DFHarley19

    DFHarley19 Active Member

    390
    0
    0
    I believe that is the problem! The float is stuck...

    A year ago, my wife's bike (2011) has problem with light on only if it was full. The light went out in about 25 miles later. I took her bike to dealer (under warranty). They found out that the float was backward! :dknow
     
  6. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Also the concern is the illumination light of gauges ceased on the small gauges.... Do you still have a battery gauge and is that light out also ???
     
  7. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    Pesky floats seem to always act up at the worst possible time...if it's not the carb, it's the fuel tank. Back in the day I got pretty good at tearing into the carb to us-stick a float on the road. Hope OP got 'er straightened out.
     
  8. 01 rk

    01 rk Active Member

    317
    26
    1
    Yes the volt meter still works and the light is working, also on in the speedo and tach.
    If the float is stuck what caused the three lights to out, just coincidental?
    The previous electrical problems ie: a fairly new battery going completly dead in just a matter of moments, then the stator and regulator going bad are a concern.
     
  9. 01 rk

    01 rk Active Member

    317
    26
    1
    What would make the float arm get stuck after seven year of working properly, is there something else that the float could get stuck on?
     
  10. 01 rk

    01 rk Active Member

    317
    26
    1
    Took the fairing off today, checked the wiring ,all ok 12v to the gauge. Replaced the burned out lights, guess it was just coincidence that three burned out at once.
    Will have to get a gasket and bolts, then remove the console and check the float.
    Thanks for all the replies.