Fine Mist of Oil on Regulator

Discussion in 'Touring Models' started by Tom-T-Bone, Sep 16, 2010.

  1. Tom-T-Bone

    Tom-T-Bone Member

    8
    0
    0
    I have an 06 Ultra that is getting a fine mist of oil on the regulator cover.....almost like a spray.......any idea where it could be coming from? I thought it might be from the filter, but I just changed the oil and filter and still getting the light spray of oil.
    Tom
     
  2. Mavagrand

    Mavagrand Senior Member

    1,250
    48
    12
    I'm thinking some oil from your recent change ran down onto your frame and is now blowing up on the regulator. Clean underneath your bike and see if it goes away. Changing the oil on a touring bike can be messy.
     
  3. sprinklerfitter669

    sprinklerfitter669 Junior Member

    982
    0
    6
    I would give it a good wash, and check again.
     
  4. Dr. Dolittle

    Dr. Dolittle Experienced Member Staff Member Moderator Contributor

    6,399
    108
    24
    Good idea - anytime you notice something new happening to your bike, your first though should be, "What have I done recently (maintenance, modifications) that might be contributing to this."
     
  5. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Yeah, if the last oil filter change was not done with proper windage/drain tray that oil gets all over. Even dealers who have the little HD orange ones on their shelves do not use 'em...drives me crazy when I see oil all over the front of an HD...!
     
  6. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,630
    68
    99
    Yeah, and it is not good for the engine mounts either. Accelerates the deterioration of the elastomer.

    TQ
     
  7. Tom-T-Bone

    Tom-T-Bone Member

    8
    0
    0
    ...Problem started right after I installed the chrome regulator cover....not after I changed the oil....I cleaned everything up good, then changed the oil, and wiped everything down again....thought it might have been coming from the filter.....went for a short ride and when I got back, I had another fine mist of oil on the cover....was wondering if it could be coming from the fork oil but I don't see any evidence of this.....can't figure it out, but thought it might be something someone else had experienced over the years.
     
  8. mouthful

    mouthful Active Member

    155
    26
    0
    Please correct me if I am wrong, it seems to me that I saw in another post that you had a OIL TEMP GUAGE installed on your Ultra. Maybe check the fittings for leakage if applicable
     
  9. Tom-T-Bone

    Tom-T-Bone Member

    8
    0
    0
    Thanks for the feedback.....that's exactly what I'm thinking....I've been out of town and haven't had a chance to check the new oil line yet...........I appreciate all the comments...will check everything again after a good clean up.
    Tom