fatboy starting with the run/off button

Discussion in 'Electrical' started by fatirish1450, Feb 22, 2011.

  1. fatirish1450

    fatirish1450 New Member

    2
    0
    0
    greetings from ireland,hi guys i bought an 06 1450 fatboy last year with 7500 miles on the clock,this morning i powerwashed her after asunday ride in poring rain.when i turn the ignition on now and hit the run button the bike starts without hitting the start button,also a couple of times i heard a grinding noise comming from the side casing on the left hand side, any help and advice on this would be greatly apreciated,thanks
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Blow out the switch housings on the bars with some air and don't use a power washer on the bike,. It's not needed and will only cause problems like this.
     
  3. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Clean the run and start button contactcs and add some dilectric grease to all the connections
     
  4. Hoople

    Hoople Account Removed

    7,198
    0
    34
    I am sure you know what that is. Get that switch dried out before you eat up a starter pinion gear.
     
  5. fatirish1450

    fatirish1450 New Member

    2
    0
    0
    thanks for the tip,wont be usein powerwasher again

    i,ll try that thanks for the tip

    havent a clue what that is to be honest :)but i get the message thanks for the tip
     
    Last edited by a moderator: Feb 23, 2011
  6. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Good luck to you, the dilectric grease is the best investment for your bike IMO

    If the starter stays engauged it could ruin the starter and the ring gear, possibly cause a melt down at the battery
     
    Last edited by a moderator: Feb 23, 2011
  7. Mad Dog Jim

    Mad Dog Jim Banned

    605
    0
    5
    I think they are trying to tell you that the starter is engaging as the bike is running