fatboy problems

Discussion in 'Electrical' started by swampdawg, Oct 17, 2012.

  1. swampdawg

    swampdawg Member

    5
    0
    0
    i have a 2000 fatboy...when riding my speedo and mileage indicator quit working and my engine lite comes on...when i slow down or come to a stop everything works again and engine lite goes out...talk to harley and they said speed sensor bad..i replaced..still doing it...now im noticing when when im not riding i can throttle the bike a lil and it does it..mileage indicator goes out and engine lite comes on...let off throttle and it works fine...any suggestions would be helpful..its driving me nuts trying to figure this out...thanks
     
  2. Jack Klarich

    Jack Klarich Expert Member

    17,965
    153
    296
    Welcome to The Forum http://www.hdtalking.com/archive/t-47714.html have a look here also, pay attention to connections at the battery before testing, clean and tight
     
  3. swampdawg

    swampdawg Member

    5
    0
    0
    thanks for the info....i got the code ..only one that came up was positive battery voltage...would a bad regulator cause this problem im having...? again thanks alot for info
     
  4. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Absolutely. But don't just replace the voltage regulator without cross checking the voltage with a meter. If you see the voltage above 14.85 at 2500 RPM, it needs to be replaced.
     
  5. swampdawg

    swampdawg Member

    5
    0
    0
    i checked the voltage at battery..when idling it reads 13.5...when i increase throttle it jumps past 16...it maybe a dumb question but how or why would a bad voltage regulator make the speedo quit and mileage indicator go out and engine lite come on...just tryin to understand all this..
     
  6. Hoople

    Hoople Account Removed

    7,198
    0
    34
    The circuits in a speedo could easily be damaged by exceeding their original design operating voltage. So by design, the circuits have a built in safety feature that will turn themselves off in case of over/excessive voltage. Sixteen volts is the design threshold for shut-down and throwing a code.

    The stator has the ability to swing voltages past 50 volts. Something has to be put into place to protect all the downstream components.
     
  7. lordharold

    lordharold Active Member

    191
    0
    2
    just had the same exact problem code 16 on same year and model checked charging system and it was a bad voltage regulator
     
  8. swampdawg

    swampdawg Member

    5
    0
    0
    sorry tank...didnt know im new here..i want to thank everyone for all the feedback...i sure hope a new regulator does it...
     
  9. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,171
    133
    132
    When replacing the voltage regulator there is a wee bit of temptation to cut and splice the feed cable into the bike electrics however that can cause a weak point so always best to feed it through the bike to its destination it can be a bit of a pest but may save you from grief at a later date

    Brian
     
  10. Hoople

    Hoople Account Removed

    7,198
    0
    34
    I am sure it will. But even if it did not fix the speedo problem, it would fix your excessively high charging voltage. That needs to be addressed regardless of the speedo issue. Batteries will overheat with that kind of charging voltage. If it has water caps, check the level.