fatboy is backfiring

Discussion in 'Softail Models' started by tucks, Jan 24, 2009.

  1. tucks

    tucks Member

    30
    16
    0
    I have a 92 fatboy it hadnt been statred for a month or so i went to start it and it backfired with flames coming out the exhaust any ideas what it could be?
    thankyou
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Sounds like it's a bit loaded up on fuel in the exhaust. May need a warm up and some servicing. Was it running right before you stored it? What did you do to it before storing it in the way of stabil in the fuel etc?
     
  3. mroleg

    mroleg Active Member

    151
    26
    0
    Also, check your vin for recalls, if you carb has 3sided fuel inlet valve it has to be changed to 4sided one or the carb keeps overflowing.
     
  4. R. Lewis

    R. Lewis Senior Member Retired Moderators

    2,183
    48
    5
    Not familar with the fatboy but -would yours be carbed or F.I. ,does it have a fuel petcock and if so was it shut off, what octane of fuel are you running in it, before you quit riding it what kind of "last ride" did you do -short around the block or a fairly long ride??????? Have you changed the plugs or anything else?
     
  5. Classynomad

    Classynomad Account Removed

    26
    0
    1
    Last edited by a moderator: Jan 25, 2009
  6. tucks

    tucks Member

    30
    16
    0
    it was running fine before i stored it i changed the fuel this morning it started then i tried it again and it backfired again

    it will be hard to run it cos it wont start its just a loud bang all the time im stuck
     
    Last edited by a moderator: Jan 25, 2009
  7. glider

    glider Veteran Member

    25,464
    108
    44
    Check and see if it is getting fuel to the carb. See if you get a squirt from the accelerator pump when you twist the throttle.
     
  8. R. Lewis

    R. Lewis Senior Member Retired Moderators

    2,183
    48
    5
    check to make sure battery is completely charged up ???????
     
  9. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,632
    68
    99
    I have a '91 EVO. Month is not that long. Since you have changed your fuel in the tank, drop the float bowl to make sure it is OK in there. Catch the gas you drain out before you drop the bowl and see what's in it.

    When you drained your tank, did you unscrew the tank fuel valve and see how much crap is on the screen? If not, you might do that part again. Mine got so bad I replace the whole valve assy with a Pingel Power Flo.

    I you still have an OEM VOES, make sure the hose is OK from the carb to the switch. Better, just replace it.

    If none of that helps, start looking for air/exhaust leaks on the intake side and exhaust side. You should find some pointers in self help.

    TQ