Fairing mount Brass Sets

Discussion in 'Touring Models' started by TonyCC, Jun 26, 2009.

  1. TonyCC

    TonyCC Member

    10
    11
    0
    :small3d015: I was installing the newest Kennedy Technology Group GPS/XM interface and while removing the fairing, discovered on of the brass set mount split and the insert loose. (I probably did this to my self with the first modification) Any suggestion on repairing this that has worked?:20:
     
  2. Lancer

    Lancer Junior Member

    495
    28
    2
    Not sure exactly what mount your referring to. But I took mine to HD for a stereo problem. The tech ordered new mounts and a new stereo for the bike. He said the mounts broke and the vibration trashed the stereo. Now I still haven't got these new parts yet. But I am out of town at the moment. But I believe this might be a fairly common problem.
     
  3. TonyCC

    TonyCC Member

    10
    11
    0
    :31:The mounting sets that the fairing mount screws go into. Brass inserted into the plastic molded stands on the fairing on the sides and bottom, in the Inner fairing on the top that hold the windshield on
     
  4. Lancer

    Lancer Junior Member

    495
    28
    2
    Gotcha, I torque those to the recommended setting and use blue locktite. Never had a problem. I was refering to the fairing mount brackets. To fix yours I would think a 5 or 10 minute epoxy should do.
     
  5. gs34

    gs34 Junior Member

    639
    28
    5
    The replacement inserts for the windshield screws is Part #16585-96.
    Not 100% sure, but I believe the fairing screws are smaller, and I don't think they make a repair insert for them.
     
  6. GreyGhost

    GreyGhost Member

    9
    11
    0
    Just an FYI, my buddy has an '06 SG, and he had his fairing mounts break twice, just from normal use/vibration. Had them replaced under warranty, but unfortunately HD uses what looks like cheap pot-metal for the mounts. He had a set fabricated out of alloy.