Evo With S&S Stumbles

Discussion in 'Engine, Fuel and Exhaust' started by Bud White, May 19, 2010.

  1. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    98 Fatboy runs great except if im at a steady throttle and apply just a tad bit of throttle it stumbles. does it all gears tonight for example on x way at 70 if i just add little throttle it stumbles twist it father takes off.

    throttle is 1/4th or less and only does ti there tried adjusting it out no go so im thinking intermediate jet is too rich as it doesnt back fire or pop

    Any tips on jetting on the S&S and where to start what #jets so i can order before i tear it apart
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Bud

    Have you checked the function and adjustment of the accelerator pump linkage?
     
  3. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    yes its not enough twisting to be the pump i did shut it off totally and same all the way one then it just ran really bad .. i mean not even a 1/16 more throttle or say holding steady at 70 and then haveing a small hill it starts to stumble holding the throttle
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    There may be too much of a gap in the linkage before it contacts the pump rod. Have you tried to readjust it to contact the pump rod sooner?

    Which S&S?
     
  5. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    yes ive adjust it and no probs there its a super E .. if ti was the pump why would it bog or stumble under load with out you moving the throttle ?
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
    This is why I say accel pump linkage, not contacting the pump and getting a squirt or possibly the pump itself?
     
  7. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    i would agree if it didnt do it when it start when you loaded it like going up a hill .. i can dial in more pump the link is good
     
  8. whatyardwork

    whatyardwork Banned

    829
    0
    4
    How old is the carb Bud?I ask because Ive already gone through 1 fuel line due to the new fuels.The explanation I got for the failure was the new fuel contains more particals that dont break down like the old stuff.

    This causes it to basicaly sand blast everything in its path.The FI bikes being anodized internaly seem to be safer from this.This makes me wonder if its possible the gas has eaten 1 of your jets?

    You may have the correct size jets,just not anymore.Just an idia.
     
  9. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    cant say bikes 98 and i bought ti used so all is a guess.. ill take it apart this week as ill have more time unless i do cams in the rkc
     
  10. Chopper

    Chopper Senior Member

    1,632
    48
    18
    Hey Bud don't know if this will help but here's the PDF for the super E & G, it gives some jetting and tuning info, I found where I'm at (4500 ft) the 68 main works well in 100+ inch motors w/28 intermediate, but the book calls for much larger jets. I would also look at the fuel coming out of the enjector nozzle, I've had to take a file and enlarge the openning a little to get a good smooth stream. You can check it by twisting the throttle with the air cleaner off and watching. Also I have seen a couple that leaked air at the plug on the top front of the carb, sucking air round the plug, only way to fix it was to send it back to S&S, the carb ran great with a new plug in it, you can test it by spraying it while it's running just like a intake leak, but be careful if the enginges hot. Good luck.
    View attachment Carbs E & G Twin Cam.pdf