EVO Troubleshooting Help Needed

Discussion in 'Touring Models' started by Jonas, Apr 8, 2010.

  1. Jonas

    Jonas Junior Member

    408
    0
    2
    My brother's bike.

    1998 Road Glide, stage 2 engine, S&S Super E carb, 24000 miles. Started making a chirping-squeaking sound. Most pronounced when giving more throttle at lower RPM's. Does not happen at a constant speed or accelerating at a higher RPM. Makes it more when warmed up. Seems like it may be coming from the carb area and may be a whistling instead of metal on metal contact. Is getting worse.
     
  2. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,310
    73
    130
    I'm certainly no expert but, Im thinking exhaust leak.

    Bodeen
     
  3. maine-e-axe

    maine-e-axe Junior Member

    732
    28
    1
    Head gasket, I would say.
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Run a compression test and check the pushrods, sometimes they rub inside the tubes
     
  5. glider

    glider Veteran Member

    25,464
    108
    44
    I'm going with an exhaust leak too.:D
     
  6. bikerjake

    bikerjake New Member

    2
    11
    0
    Don't overlook an intake leak. Several o-rings in a S&S up there.

    Mike
     
    Last edited: Apr 10, 2010
  7. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    remembering back in my EVO days... my 97 dyna .....

    I think i remember a problem with the stock oil return galley(cam chest),the squirrel cage mods I did and the replacement of the PLASTIC (if memory serves right) squirrel cage to a metal ones and replaced the plastic gears there also...

    They are TIMED with the pistons up and down, careful!!! I know I also took a die-grinder and enlarged the area ( rounded block, removing sharp edges front of cage per instructions) for better flow of OIL and AIR flow from the pistons going up and down....?????????

    MY noise was a WOOO hooo sound and right in tune with the pistons up n down.... thinking the above CURED the noise... (memory???)
    This MAY NOT be the noise in yours but was in mine.. If all else fails look here....

    TQ1 may have something he "remembers" here. seems he posted back on a similar post i did long ago...

    hope this helps "food for thought"

    signed....BUBBIE
     
  8. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Bubbie I think you are talking about the breather valve, they were plastic and they ruined alot of them and scored the cam chest also. You could alter the screen and change the timming as you refered to here S S made a much better gear and better choices of washers for the end play
     
  9. Fossil

    Fossil Active Member

    335
    28
    1
    I will go with the majority and suggest an exhaust leak or maybe a heat shield is loose. Fossil
     
  10. Jonas

    Jonas Junior Member

    408
    0
    2
    My brother called me this morning.

    He has been working on this problem. He replaced parts on the intake seals, and exhaust gaskets, both helped. Then today on his way to work the front clyinder head gasket totally went.