Engine shake

Discussion in 'Touring Models' started by 2010roadkingBlack, Sep 22, 2010.

    Quick question. My friend has a 2008 Heritage softail with the same 96 motor as my 2010 Road king. My engine has always shaked pretty hard even with the stock pipes. Since I have added slip ons it still shakes hard about the same. My buddies Heritage is really smooth you can hardly see it shake at all. He has Rush slip ons on his. I am going to the dealer tonight for my 2500 service. Any help would really be appreciated.
     
  1. Breeze3at

    Breeze3at Well-Known Member

    4,645
    83
    124
    Two different engines. You have the "A" engine which relies on rubber motor mounts to quell vibration. That's why it shakes at idle, it sits on rubber.
    Softails have the "B" engine which have chain driven counter balancers (weights) in the right side case to deal with the vibrations. Look at the two engines side by side. notice the difference in the right side engine cases (not the chrome covers). Also, your motor mounts bolts are vertical, his are horizontal. Now that you know the difference, you can start debating whose is smoother.:D
     
  2. Appreciate the help.
     
  3. sprinklerfitter669

    sprinklerfitter669 Junior Member

    982
    0
    6
    One thing i noticed, with the A engine, is the faster you go, the smoother it feels, where as the B engine, the faster you go, it seems to feel like it vibrates. :s
     
  4. Thanks everybody for the help. Like I have said before I am new to Harley's and this is my first one. Last night when I went to the dealer for my 2500 mile service. They started up some other bikes like mine and most of them shook more than mine did. At least now I am sure there is nothing wrong with mine.
     
  5. GnatMan

    GnatMan New Member

    2
    0
    0
    I just purchased a 2009 RoadKing Police version. It almost shakes my teeth out on decleration, and idle at each traffic light. But at speed it is as smooth as ice. I'm already questioning my choice of bikes. There has to be a solution to this issue.
     
  6. eleft36

    eleft36 Junior Member

    441
    26
    1
    May I quibble, My bike does not represent this quote. It is smooth all the way through My riding comfort zone, 0 to 75:bigsmiley16:

    Al

    :USA
    :CONNECTICUT
     
  7. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Sounds intense. I agree with Smitty, something may not be right. More info on your ride is needed. If previously owned, hard to say since you did not feel it from new. What was your previous ride?
     
  8. karlsbike

    karlsbike Active Member

    264
    0
    3
    GnatMan
    Have you checked your front motor mount? I had a similar experiece when mine came loose...
    Check also your upper link, and your rear swingarm pivot axle assembly (you can peek through the chrome cover in the rear footboard supports, but better to take them off for inspection).
    To try to keep to the topic here - the 'A' motor shakes, the 'B' is buzzing...
     
  9. GnatMan

    GnatMan New Member

    2
    0
    0
    This is my first Harley, I previously rode Kawasakis. I have changed out the gas, and that has helped some. Perhaps since it sat for a couple of months it has gummed up some. I'll have to ride it some more and see.