Engine problem with 2006 Road King

Discussion in 'Touring Models' started by xcavater, Jun 12, 2012.

  1. xcavater

    xcavater Member

    I'm buying a 2006 RK with stage 1 (SE air filter, Power Commander 3 and Rineharts true dual) with 6000 miles from a friend. Bike hasn't been ridden in 1.5 years due to medical problems. Bike was stored with fuel in tank but been run to operating temp during that time.
    No problems when last ridden. I filled tank from 1/4 to full and started test ride.
    I have put 300 miles on since . Within the first 75 miles, bike developed a engine cut out condition. While riding it feels like ignition is momentarily shut off and the bike bucks, continues to run, just an annoyance. Rode and additional 25 miles home, shut bike off, added fuel injector cleaner. Next day, went on a 200 mile ride. First 75 miles, all was well then the cut out condition returned. Stopped bike, and filled tank, put 4.5 gallons in. Bike ran fine rest of day. Now it seems to be running rough, not as much power.
    Talked to local HD, and they say pull PC3. Talked to PC, and they say doubt the problem is in their box.
    I feel fuel related.
    I need a direction to proceed before I pay for the bike. Should I pull the fuel pump and replace filter/lines?

    Sent from my ADR6400L using Tapatalk 2
    Last edited by a moderator: Jun 12, 2012
  2. ironmark

    ironmark Junior Member

    New fuel filter wouldn't hurt, the earlier model bikes have had a history of the fuel lines cracking inside the fuel tank, this will cause the bike to have running problems that seem to be fuel related. When the fuel level drops in the tank to the point were the crack is in the fuel line the fuel pump will start to suck air and the bike will run poorly.
  3. Mavagrand

    Mavagrand Senior Member

    +!. My thoughts exactly.
  4. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    Remove fuel cap and turn switch on and look and listen in the tank. If see fuel splashing or hear it hissing. You have a fuel line that has a whole in it. Best to dp this when the tank is low on fuel. The other tell tale sign is the fuel pump running a lot while engine is off.
  5. xcavater

    xcavater Member

    The fuel pump primed when ignition is turned on doesn't run past that for up to 1/2 hour. Tank is full I'll pump it down next.

    Sent from my ADR6400L using Tapatalk 2
  6. Wayne R

    Wayne R Active Member

    I have an 02 Roadking and it did what you describe turned out to be bad intake manifold gaskets
  7. STEVE07

    STEVE07 Well-Known Member Staff Member Super Moderators

    My guess is moisture.Drain all you can from the tank,then re-fill and add some Seafoam to the tank.Ride that tank out then change the spark plugs.I am willing to bet that it will run like a top after that.
  8. pjciii

    pjciii Member

    i had a 2006 road king and the problem was the injectors on some models were recalled, it had an 8 degree injector and it was replaced with a 25 degree injector. you dealer should be able to read the injector number without tearing it apart and see if your bike is covered by the recall. if this is not changed it will run fine for awhile and the spit and sputter from time to time...also had a 2005 night train and the fuel sending unit started to go out and it acted the same way. my 2 cents.
    p.s. that is part of the problem with people buying bikes and not putting any miles on them. had it been riden the previous owner could have caught this and had it fixed under warrenty..that is a rant.

    also at about 20k pay for them to check your cam chain tensioners or do it yourself...but watch them..
    Last edited by a moderator: Jun 16, 2012
    1 person likes this.
  9. xcavater

    xcavater Member


    This nails my complaint 100%. The MoCo updated injectors 2/2006. My bike was manufactured with the old injectors 10/2005. It also has a lousy idle at times, almost feels like the timing is retarded.
    New injectors on the way.
  10. ickysticky74

    ickysticky74 Active Member

    Is it hard to locate and tell what injectors you have. I have a 2006 Electra Glide. Would the injector problem be on my model also?