Engine mount busted

Discussion in 'Touring Models' started by Ozoneman, Sep 23, 2008.

  1. Ozoneman

    Ozoneman Active Member

    322
    26
    0
    I took my 2006 Ultra in for its 15,000 service and told them to be sure and check the motor mount. Yep, they found it busted. Does this happen to everyone? I didn't realize I had a problem. Everything seemed to be OK. But I've heard that the motor mount has been a problem. Be sure to check them out even if you don't notice anything.
     
  2. Bud White

    Bud White Well-Known Member Retired Moderators

    3,270
    48
    2
    if you change your own oil try not to let it drip on the mount as this will cause the rubber to split from the metal also
     
  3. jonnierock

    jonnierock Member

    42
    16
    0
    Ozoneman,
    What did they replace your mount with, (HD or after market) and does your scooter vibrate more now, than before.
    Thanks Jonnierock
     
  4. Ozoneman

    Ozoneman Active Member

    322
    26
    0
    It is in the shop today. I won't get it until tomorrow. I imagine they will replace it with HD parts since it is under warranty and is at a HD dealership.

    As far as any vibration the guy told me that I wouldn't notice a problem because the mount gradually breaks lose and you don't notice much of the small changes from day to day riding. He said you might notice it if you rode one bike with a broken mount and then immediately rode another bike without a broken mount. I'll have to see when I pick it up if I notice any difference.
     
  5. jonnierock

    jonnierock Member

    42
    16
    0
    Ozoneman
    When you get it back, post and let us know how smooth it is.
    Jonnierock
     
  6. Ozoneman

    Ozoneman Active Member

    322
    26
    0
    To be honest, I don't know that it rides any smoother. It may but the difference that I think I may feel, may be that I'm expecting it to ride smoother. However, I am sure that when I sit at a stop light, when holding the grips my hands and arms shake more at idle.