Engine light/sputtering

Discussion in 'Touring Models' started by ultraclassic, May 1, 2008.

  1. ultraclassic

    ultraclassic Member

    7
    11
    0
    I had recently posted a question reference popping when decelerating. After riding now the popping seems to have gone away and I'm very cautious to use the right octane level.

    Recently this has started happening: While riding the engine light will come on, and then a few seconds later the bike will "sputter". When I try to accelerate, the bike hesitates and sputters and then when it returns to normal I perceive there to be a loss of power and a different engine sound.

    When I am at a light and idling, the engine light will come on, the RPMs go up to 2000 and the bike will begin to stall after. I have to rev the engine sigificantly to keep the bike from stalling and it's difficult to get going. When it returns to normal after a few moments, I smell gas.

    Think water is in the line or tank somehow? I'm in Missouri I've gotten caught in some torrential down pours a few times.

    Very disconcerting as the first time this happened I was passing a slower vehicle and when in the other lane the bike began to hesitate and I made it back nearly in time to avoid a head on collision, which to say the least would have ruined my day.

    I appreciate the expertise you folks provide! Excellent forum!
     
  2. glider

    glider Veteran Member

    25,464
    108
    43
  3. ultraclassic

    ultraclassic Member

    7
    11
    0
    dry gas or sea foam????
     
  4. glider

    glider Veteran Member

    25,464
    108
    43
    Sea Foam - Harley Davidson Community

    Dry gas can be bought in any auto parts store and is basically alcohol which mixes with the water and makes it passable through the engine fuel delivery system. Ethanol in fuel like you see in some areas at the pumps also helps to pass the water buildup in a fuel tank.
     
  5. ultraclassic

    ultraclassic Member

    7
    11
    0
    OK. Will try it. Was also thinking of replacing the plugs too, just to be sure.

    Never heard of dry gas or sea foam. Yeah, i'm sheltered.
     
  6. ultraclassic

    ultraclassic Member

    7
    11
    0
    sea foam did not work. Any other suggestions?
     
  7. Fisher

    Fisher Account Removed

    341
    0
    1
    The engine light on while running is a current code.Something is amiss and needs attention soon.Find and fix the problem before it gets real expensive.Like the others said call up the codes and post up the results.
     
  8. ultraclassic

    ultraclassic Member

    7
    11
    0
    Dealer said it was the engine temp sensor which went bad. I'm not exactly sure how the sensor went bad (only 18K miles). Issue apparently is resolved now (as of an hour ago) but brings up another issue/question:

    Even on the new bikes, are there items which habitually have less of a lifespan then what would be routine such as oil filters, fluids, etc? I would have thought the lifespan of many of the electronics and parts would live well past the 18K mark.

    r/
    UC
     
  9. glider

    glider Veteran Member

    25,464
    108
    43
    Temp sensors, crank sensors, VSS (speed) sensors all have a history or early retirement, not in mass but they do go bad.
     
  10. Fisher

    Fisher Account Removed

    341
    0
    1
    It's a thermistor and they haven't got making them down yet.Probably be a couple years before they get it right for harsh environments.Just my 2 cents.