engine light on,hard throtle only

Discussion in 'Dyna Models' started by nobleff517, Aug 3, 2010.

  1. nobleff517

    nobleff517 Member

    10
    0
    0
    light comes on when im hard on gas then when i back off it goes off? what the world
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
  3. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    83
    101
    Have you got an oil light on that bike? It is not coming on, right? Check your oil level anyway just to make sure.

    TQ
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Does your 07 have the torque smoothing download? I would have that checked, mine slipped thru yhe cracks and did all kinds of crazy things, poor idle and long crank times to name a few
     
  5. Redfish-Joe

    Redfish-Joe Senior Member

    2,307
    48
    10
    Just for the heck of it check your plug wires where they clip onto the plugs. One could be a little loose. This happened on my friends 04 Classic.
     
  6. maine-e-axe

    maine-e-axe Junior Member

    732
    28
    1
    Air filter clean?:newsmile030:
     
  7. glider

    glider Veteran Member

    25,464
    108
    44
    I have to go with Joe on this one.:D
     
  8. nobleff517

    nobleff517 Member

    10
    0
    0
    well gang my throtle body moves up and down! the race fueler from harley i think is bad cause the lights are backwards unless they misprint in instructions! and my oil light flickers real dim! i know i cant tune it due to throtle body issues but what is oil light deal? i changed oil yesterday 3 qts like it says and when i drained it, 1.3/4 qts came out!! i did last service 3 weeks ago. my tfi went bad when i was ridding and bike shut down do to over heating i think i lost oil when it got hot,motor ate it? my pipe is dry and lil sooty no oil leaks,and air filter is new along with plugs
     
  9. Hoople

    Hoople Account Removed

    7,198
    0
    34
    You went from a simple "check engine light" to this in one day. Wow.
     
  10. nobleff517

    nobleff517 Member

    10
    0
    0
    ok! found wire was pinched under tank that goes to oil light fixed that,now im taking it to my hd dealer to put new intake seals on and hook it up to diagnostic tech. then they will find what sensor is bad if any.heck fixxing intake may cure it all! also got prices on map,tps,mass air flow my cost...-20% for being fireman 81.00 and that includes intake seals